8.2.5 arctium launcher

Here is a link to the launcher that I use to run 8.2.5.32750:

https://mega.nz/#!yHBwGC4A!9jXlYVIBJMw2yePcfOA-M_ifcG3gRM0UzFT67pvjZZc

If you’re receiving “incompatible” when attempting to log into your realm then you can change the value in the file called .build.info

is this launcher also useable for 8.3034220?

I found a sutable launcher!