auf lokalen server verbinder der eine andere realmlist hat?

huhu

hab folgendes problem gerade. mein server läuft hier bei mir zuhause nur ist dieser online auf eine andere realmlist die nicht mir gehört. andere player können auf den server connecten nur bei mir bleibt er bei Verbindung Hergestellt hängen und geht nicht weiter.

zu den server ein debian linux server version 7.7

zu meinen rechner linux mint 17 mit aktueller wine version

auf den server läuft die aktuelle 3.3.5a version.

auf dem rechner die dazu passende 3.3.5a version.

ich habe die realmliste auf die externale ip gestellt.

auf der externalen auth datenbank ist einmal

address local address

die dyndns online ip addresse

was kann ich tun um auf meinen server zu connecten?

Hallo,

du hast im deiner Auth Datenbank eine Tabelle, die realmlist heisst.

Es gibt da zwei Spalten.

Die eine heisst “local adress” und die andere “adress”

die Lokale sollte die (ich schätze mal) 192.168.x.x haben und die adress deine “öffentliche”

Einige Router mögen den Loop nicht.

Was hast du in der Konfiguration deines Servers bei BIND IP drinnnen? authserver.conf sowie worldserver.conf?

Was hast du in der realmlist.wtf deines WoW Clients hinterlegt?

Das Problem kriegen wir sicher raus /emoticons/default_wink.png

Lg Byte

habe den authserver nicht bei mir stehen steht bei einen freund in der usa er hat da in der address und auf local address <127.0.0.1>

ich weis nicht was er in der authserver.conf für eine bind ip drinne hat auf meiner worldserver.conf ist es immer noch 0.0.0.0.

in der realmlist hab ich einmal meine internal ip <192.168.x.xxx> und die external ausprobiert da beides nicht klappte hab ich hier einen topic aufgemacht /emoticons/default_smile.png

bei local adress kann eig einfach localhost oder 127.0.0.1 stehen bleiben. sofern auch die ports korrekt weitergeleitet werden müsstest du den fehler wohl in den configs suchen

eher die 192.168.X.XXX addresse /emoticons/default_wink.png auf meinen rechner läuft TC nicht sonder auf meinen server /emoticons/default_smile.png das hatte ich auch schon gemacht, nur das ich mit meinen rechner drauf connecten konnte.

ich kahm bis vor die charauswahl (handshaking) dann war schluss gewesen und es ging nichts weiter

und wo läuft die db?

Mit dem selben Problem habe ich gestern auch zu kämpfen gehabt. Ich vermute mal, das Du Dich von einem anderen Internetanschluß auf Deinen Server einloggen kannst, nur eben nicht aus Deinem eigenem Netzwerk heraus. Das ist beispielsweise ein großes Problem, wenn man den Kabeldeutschland-Router hat. Da lässt sich die Loopback funktion nicht abschalten und somit kann man sich selber über seine eigene öffentliche IP nicht erreichen. Da lässt sich auch nichts dran ändern, soweit ich das jetzt festgestellt habe. Solltest Du einen anderen Anbieter bzw. Router haben, gucke mal, ob es dort irgendwo eine Funktion Loopback gibt. Das sollte dann das Problem beheben.

Ob es das Problem ist, lässt sich sehr leicht testen, wenn Du Dir beispielsweise mal einen ganz simplen Webserver aufsetzt und versuchst diesen von Deinem Rechner aus, über Deine öffentliche IP-Adresse zu erreichen. Sollte das funktionieren, dann liegt es wohl doch an etwas anderem. Ansonsten wird es wohl nicht funktionieren.

 die haptdatenbank läuft auf meinen server die auth datenbank ist in den usa /emoticons/default_wink.png

 

 

 jap genau das ist das problem ich kann mich bei meinen eltern zuhause einloggen in meinen server nur hier bei mir nicht. ich hab nen speedport w723V ich müsste mal schauen ob er das unterstüzt ich sag dir dann nochmal bescheid

edit: so es scheint als hätte mein router nicht die option loopback drinne (was soll man auch von einem telekom gerät erwarten) ich müsste mal schauen ob ich nicht irgentwie diese funktion ausschalten könnte

Entweder hab ich das Problem falsch verstanden oder die Lösung ist ganz einfach

Wenn du einen Server aufsetzt dieser auf deine Öffentliche IP hört und du durch das genannte Loopback nicht darauf verbinden kannst
Ändere doch deine Reamlist zu set realmlist localhost oder ebend wenn es ein anderer PC ist die local IP vom PC evt. 192.168.xxx.xxx
da du ja den Server local betreibst bzw. von dem PC aus der auch zum Verbinden genutzt wird
also brauchst du die Öffentliche IP garnicht
Alle anderen hingegen MÜSSEN über die Öffentliche IP Verbinden.

Ich habe auch einen Kabeldeutschland Router mit diesen kann ich meinen Lokalen Webserver auch nicht erreichen über die Öffentliche IP
bei Telekom damals selbiges.
Benutze ich aber Localhost oder 127.0.0.1 kann ich verbinden