bnetserver "Entry point not found" SSL_CTX_set_ciphersuites

Greetings, all.

I just finished carefully following the instructional guide listed here. Everything went according to the documentation with no major issues. The mmaps extraction did have to run overnight but I assumed that was due to the lower end PC specs it was running on.

Fast forward to just now and I have everything configured and ready to fire up. I get all my configs updated and start the bnetserver.exe only to receive the following error:

“The procedure entry point SSL_CTX_set_ciphersuites” could not be located in the dynamic link library"

It then provides me with a file path for my libmysql.ddl file ( which is in the same directory as the bnetserver )

I checked the forums and noted that it might be a glitch or issue with that particular DLL so I went online and downloaded a 64bit ( supposedly ) libmysql.dll and replaced it in the bnetserver directory and tried again. This time the program actually fired up but the command window gave me an error stating that the MySQL version 5.7 was not the one used to compile bnetserver ( 8.0 ) which is accurate as version MySQL 8.0 is what I have installed on the server ( it was already installed prior to doing the Trinity tutorial ).

I feel like this is an issue because the program was compiled on 64bit and the libmysql.dll might be a 32bit type but I’m not sure. Coming from a programming background it also sounds like there is a function missing in the MySQL 8.0 libmysql.dll that was present in a version used by bnetserver. I have already tried to recompile and I get the same error. Any help is appreciated.


I may have answered my question. It appears maybe TC isn’t compatible with MySQL 8?

But perhaps experts can still weigh in so I can be sure.

mysql support was added 5 months ago.

Strange. I downloaded MySQL 5.7, ran cmake again and made sure it referenced the 5.7 install, recompiled and everything worked flawlessly. ( this is is the master branch ). I’d much rather use the up to date MySQL version so I’m not sure why it failed using it.

You are supposed to use libmysql.dll from the installation of mysql that cmake found and used to compile

I’m using mysql 8 and openssl 1.1.0 just fine

I did so on all three compiles. The first two used 8.0, the second I downloaded mysql 5.7 and compiled again. Cmake used 5.7 and it worked. When cmake found 8.0 it did not. Its working now though.