Broke my Worldserver-kicked for overspeed ping

So… last night dozed off in the middle of a Deadmines run so I logged and went to bed. When I logged back in this evening it seems that my server has become borked. When I logged back in my toon was still in Deadmines but all the mobs were unresponsive and showed ‘Unknown’ for the name. Tried the unstucker, disconnect. GM tele $home, disconnect. Log back at hearth location- more Unknown NPCs, disconnect. Cleared client cache… Check server console and I was getting disconnected because…

WorldSocket::HandlePing: [Player: xxxxxxx (GUID Full: 0x0000000000000002 Type: Player Low: 2, Account: 2)] kicked for over-speed pings (address: 192.168.1.xxx)

Tried creating a new player to test with and it is happening with new toons too.

Suggestions? Pinging my domain returns with <1ms, but in-game latency is 8-9k. Is it possible for this to be a corrupted database? Corrupted client files? GM account stays logged in but shows the effects of the lag. I’m still waiting for it to catchup from the string of .teles I fired off. I don’t expect disabling the ping checks to fix this… worldserver is using 0.02% of one core (2 dual-core processor machine) and 12% of system memory.

/edit: 3.3.5 server, recent-ish build, same with DB. Server is currently powered down but if specific revision is insisted on I’ll boot it later to get it.

Not sure what or how, but it seems that my DB may have been causing it for whatever reason. Dropped auth, world and characters then rebuilt the databases and all was well again. Just lost all my accounts characters and custom items.