Cannot Find ZLIB

Hi there.

I am trying to compile Trinity Core and I have managed to troubleshoot all of my other issues. The only thing (I hope) I am stuck on now that is stumping me is a CMake error saying that it cannot find ZLIB.

After typing cmake …/ -DCMAKE_INSTALL_PREFIX=/home/dlloyd/bin i get the following at the bottom of the output:

CMake Error at /usr/share/cmake-3.2/Modules/FindPackageHandleStandardArgs/cmake:138 (message):

Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version “1.2.8”)

Call Stack (most recent call first:)

/user/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:374 (_FPHSA_FAILURE_MESSAGE)

/user/share/cmake-3.2/Modules/FindZLIB.cmake:110 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)

/dep/zlib/CMakeLists.txt:13 (find_package)

I am installing this on Ubuntu Server 14.04.4 (which I just realized as I am typing this that I should have been rocking version 16).

Any help would be fantastic.

[FONT=courier new]sudo apt-get install zlib1g-dev[/FONT]

@Gacko any reason why zlib has been removed from the wiki install guide? https://trinitycore.atlassian.net/wiki/display/tc/Linux+Requirements

Hmmm… odd. During my troubleshooting, I installed that particular package. I just installed 16.04 so let’s see how this goes!

Wohoo!!! Everything is coming up Milhouse! Thank you so much for your help.

i get the same error with ubuntu 16.04, [COLOR=rgb(39,42,52)]sudo apt-get install zlib1g-dev is already installed

Works for me on 3.3.5a on Debian 8.5

i have the same problem, using Ubuntu 16.04 and have zlib 1.2.8 installed

here:

– Detected 32-bit platform
– UNIX: Using default configuration directory
– UNIX: Using default library directory
– UNIX: Configuring uninstall target
– UNIX: Created uninstall target
– UNIX: Detected compiler: /usr/bin/cc
– Using mysql-config: /usr/bin/mysql_config
– Found MySQL library: /usr/lib/i386-linux-gnu/libmysqlclient.so
– Found MySQL headers: /usr/include/mysql
– Found MySQL executable: /usr/bin/mysql
– Found git binary : /usr/bin/git

  • TrinityCore revision : 94f425c6d5e9 2017-12-10 12:22:17 +0100 (3.3.5 branch)

    • TrinityCore buildtype : RelWithDebInfo
  • Install core to : /home/glene/server

    • Install libraries to : /home/glene/server/lib
    • Install configs to : /home/glene/server/etc
  • Build world/auth : Yes (default)

    • Build with scripts : Yes (static)
    • Build map/vmap tools : No
    • Build core w/PCH : Yes (default)
    • Build scripts w/PCH : Yes (default)
    • Show compile-warnings : No (default)
    • Use coreside debug : No (default)
    • Show source tree : Yes (hierarchical)
    • Use GIT revision hash : Yes (default)

CMake Error at cmake/macros/FindBoost.cmake:1204 (message):
Unable to find the requested Boost libraries.

Boost version: 1.58.0

Boost include path: /usr/include

Could not find the following Boost libraries:

      boost_system
          boost_filesystem
          boost_thread
          boost_program_options
          boost_iostreams
          boost_regex

No Boost libraries were found. You may need to set BOOST_LIBRARYDIR to the
directory containing Boost libraries or BOOST_ROOT to the location of
Boost. If you still have problems search on forum for TCE00020.
Call Stack (most recent call first):
dep/boost/CMakeLists.txt:44 (find_package)

CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version “1.2.8”)
Call Stack (most recent call first):
/usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake-3.5/Modules/FindZLIB.cmake:124 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
dep/zlib/CMakeLists.txt:13 (find_package)

– Configuring incomplete, errors occurred!
See also “/home/TrinityCore/build/CMakeFiles/CMakeOutput.log”.
See also “/home/TrinityCore/build/CMakeFiles/CMakeError.log”.

i’m new to this sorry…

Same error with a Debian 9

zlib1g-dev already installed