Client level higher than current server release level

I downloaded the client yesterday afternoon and see that the current release level is at 7.0.3.22423, which apparently includes a patch release beyond Trinity’s 7.0.3.22410 server release level.

Can (1) the latest patch be backed out, or if not (as I suspect is the case), (2) is there a way to download the client and “force it” to not progress beyond the 7.0.3.22410 level ? Thank you.

No on easy way.

aw fuck, I forgot to update the announcement thread

The supported version IS 22423 as of https://github.com/TrinityCore/TrinityCore/commit/e6ddb9f2220b045d76e1c3b796fc06b55d6abf4b (6 days ago)

Thanks for the updated info, Shauren.