CMake Compiling Error

I am running Windows 10 Pro 64 bit

32gb RAM and a i5 3470

I have followed all instructions quite thoroughly and I am still receiving errors when trying to compile with CMake (I am testing a Linux version of this through a VM Ubuntu 15.10 and its working 100% so far, with a couple minor errors I was able to resolve) however I cannot for the life of me figure this problem out. I have tried uninstalling and reinstalling VS 2013 about 4-5 times now and still the no prevail. If some one could help me get through this problem that would be great! I have attached a error log to this post.

[ATTACH]1742._xfImport[/ATTACH]

Side note… I finished the installation of the Linux side, and it appears I am having troubles creating a new account. I am not very familiar with SQL, so I’d prefer to stay clear from that if I have to; it’s indicating under “Final Steps” to…

3.3.5

Type: account create

Example: account create test test

Type: account set gmlevel 3 -1

Example: account set gmlevel test 3 -1

Log in with account test and password test through wow.exe.

Where am I to type this in? I tried typing it in after running “authserver” then tried connecting. I was able to connect to the server, but it was telling me that the username and/or password was incorrect.

Normally you type this in the worldserver.exe once it has finished loading everything. Should say “account created” same as setting the gmlevel. Also did you change the login in the wow to your ip that you are using? If the account was created it will show in your DB under auth.account.

Alright, I managed to create the account. I was able to login successfully, however now I cannot login to the realm.

When I click on the “Trinity” realm, it just takes me back to the realm list and doesn’t actually log me into that realm.

Was both auth and worldserver running?

Yes, I have them both currently running right now

I managed to fix the connection issue with the Linux side; I forgot to go into the SQL database, under the auth table and change the default IP to my external IP address.

However, I still haven’t managed to fix my issue with the Windows side… does anyone know any fix to this?