Disable client login without modified wow.exe version

I’m trying to disable the login without my custom wow.exe version(3.3.5a modified to 1.0.0 56789)

Buy when I delete all the prebc accepted clients or postbcaccepted clients like this

static RealmBuildInfo const PostBcAcceptedClientBuilds[] =
{
    {56789, 1, 0, 0, ' '},
    {0,     0, 0, 0, ' '}                                   // terminator
};

static RealmBuildInfo const PreBcAcceptedClientBuilds[] =
{
    {0,     0, 0, 0, ' '}                                   // terminator
};

A normal wow.exe with 3.3.5a version can enter

How i can only enable login with 1.0.0 56789 version and disable all the others??

[FONT=‘Helvetica Neue’]Client modifications are UNSUPORTED on trinitycore.[/FONT]