Failed to run MSBuild command:

Hello I try to set up an my frist 4.3.4 Server. So i start reading the compiler guides. So far so good. But I have a problem with Cmake:

CMake Error at CMakeLists.txt:15 (project):
Failed to run MSBuild command:

MSBuild.exe

to get the value of VCTargetsPath:

I have
  • Visual Studio 15 2017 + C++ developmenkit

  • all Visual c++ updates

  • Cmake 3.9

-Git ext

-MYSQl 5.6

I get this massge everytime I press Configurate while try to compile into Built.

Ok, I guess I forogot an Configuration. And now its says:

CMake Error at cmake/macros/FindZMQ.cmake:84 (message):
Could not find ZMQ libraries/headers! Please install ZMQ with libraries and
headers
Call Stack (most recent call first):
CMakeLists.txt:64 (find_package)

I have installed ZMQ 4.0.4 with all features. I also restart my Computer

Are you sure you are not mixing up libraries because it looks to me you are mixing up libraries and that is why you are still getting the error I could be wrong but it is not much to go by for errors when trying to look at the log there should be more to it, but from what I can see you look to be mixing up the libraries from 64 to 32 bit structure.

hey, thanks for your reply. What do you mean I mixed up the libaries? All I did was adding the 64 bit structue to all my configurations and have never add a 32 bit to the structure. But I found out that C:/Program Files/ZeroMQ 4.0.4/lib/libzmq-v120-mt-4_0_4.dll it is ending with a “.dll” I have tried to change it to .lib and also did it for everyone in this folder but still not working. But maybe I have scrued up somewhere an config.

Also the Cmakelist.txt doesn’t show me anything which is related to 0mq. It doesn’t even show me any Error or Warnings. As far as I can tell.

You should leave the files alone don’t change them because in the bin folder they are dll files but in the lib folder inside zero zmq 4.0.4 you should see lib libraries when you go inside the lib folder. I take it you are not seeing the lib folder? Also have you tried reinstalling ZMQ to see if that takes care of your error.

You want to make sure everything is 64 bit, not saying you don’t have them 64 bit just putting that out there. Let me know I will be on for a while today so I will keep checking this post. We will get you up and running or I won’t go to sleep until we do.

OK, you can go to bed and take a sleep. I’m currently at work and I will check it as soon as I’m at home

— Canned message start —
This thread is not related to the official Trinity codebase and was moved to the Custom Code section.
Please read the stickies next time.
— Canned message end —

Ok I have the files. So what I did was, I changed in the Value (cat.) the path to the directory now it kinda works but openssl has now issues. So it seems like, that he can’t use 1.1 version but 1.0.2 cant be isntalled with Windows 10? If I try it it says it is not compatible

So finally it works. CMake went well TrinityCore.sln is working fine. Could creat the Build with no problems.

Now my Question:

libmySQL.dll → C:\Program Files\MySQL\MySQL Server 5.x\lib
libeay32.dll, ssleay32.dll → C:\OpenSSL-Win64\ or C:\OpenSSL-Win32\ (depends on if your core is 64-bit or 32-bit)

Do i jsut Copie theem or cut them out and put it into my folder where autserver.exe and world.server.exe is?

I was about to say you need to make sure you installed the right openssl the one that is e does not normally work for trinitycore but the version L does, but good glad to see you got it working. Also remember when you copy those to the release directory where the main build is you need MySQL dll, and you need the ZMQ file as well and everything else should work just fine for you. Sorry not the ZMQ in that way as long as it is installed, it has been a bit since I ran 4.3.4 since it is not the main branch.

So isntant of

libmySQL.dll i replace it for libmySQL.lib? Or Both?

For 4.3.4 you need libzmq-v120-mt-4_0_4.dll and libmysql.dll with dbc, maps, vmaps and mmaps. Mmaps is not a must but it is strongly recommended.

Alright I do have them. I just put

mapextractor.exemmaps_generator.exevmap4extractor.exevmap4assembler.exe

into my client and get those stuff ready.

So i have vmaps, mmaps, dbc, maps. Question!

I had a repack before on my PC( still have it). the VMAPs, mmaps etc. has less Memory. compared to the once I jsut created.

How is this possible? I though the files/maps etc. should be the same or is this somehow effected by smth else?

Easy answer! The repack will always be out of date and inefficient. The ones you just created are new and improved.

Thank you, what I though. Ok right now I’m a litle bit confused about the next step. (I’M sry that I ask so much but i’m new to this whole thing)

"First of all you need to find the two default config files (named worldserver.conf.dist and authserver.conf.dist (bnetserver.conf.dist in master) ) and copy these to their namesakes without the .dist extension.

You can find them within your RelWithDebInfo folder"

So does that mean I copy worldserver.conf.dist and authserver.conf.dist (??bnetserver.conf.dist??) into the bin folder? I’m sry English is not my native-language so my understanding is not very well :smiley:

worldserver.conf / authserver.conf (bnetserver.conf for 6.x/master) (you must remove .dist from worldserver.conf.dist / authserver.conf.dist / bnetserver.conf.dist files to obtain them)

Scroll down to the LoginDatabaseInfo, WorldDatabaseInfo, and CharacterDatabaseInfo config options and enter MySQL Server login information for the server to be able to connect to your database.

On a newly compiled config, you should have the following values:

	LoginDatabaseInfo = "127.0.0.1;3306;trinity;trinity;auth" [B]worldserver.conf / authserver.conf (bnetserver.conf for 6.x/master)[/B]    

WorldDatabaseInfo = “127.0.0.1;3306;trinity;trinity;world” worldserver.conf
CharacterDatabaseInfo = “127.0.0.1;3306;trinity;trinity;characters” worldserver.conf

		[B]source: [https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130046/Server+Setup](https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130046/Server+Setup)[/B]

I’m confused need help, please!! :cry:

I have to ask what branch are you compiling for is it 7.2.5, also just remove the .dist extension off the files and you do not have to look for them because when you compile the server they are in the release folder. I don’t mind helping ask your questions don’t feel bad about it because I love keeping my brain working lol.

well I looked up on google: “Branch 4.3.4 WoW trinity” and took the first solution which google showed me. So I hope I took the right branch :o

so baiscly just delete “.dist” and have the config file ready? Do I need to add something inside the config files?

ok, it worked.but the worldserv.exe shows me this message, Afterwards the system crashes.

[1146] Table ‘world.updates_include’ doesn’t exist
Your database structure is not up to date. Please make sure you’ve executed all queries in the sql/updates folders.
Do i need to add something into an folder?

World database is up-to-date! Containing 8 new and 2992 archived updates.
Realm running as realm ID 1 region 2 battlegroup 1
Using World DB: TDB 434.21
Using enUS DBC Locale
Missing name MonsterSight in config file C:/Trinity/Build/bin/RelWithDebInfo/worldserver.conf, add “MonsterSight = 50.000000” to this file
Will clear logs table of entries older than 1209600 seconds every 10 minutes.
Client cache version set to: 21
Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
Map file ‘./maps/0004331.map’ does not exist!
Please place MAP-files (*.map) in the appropriate directory (./maps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!