Golden arrow on Mini map for quest

[COLOR=rgb(255,255,255)]Hi so i started fixing quests on the trinity core couse i wana help you guys out with scripting… but anyway i got the quests working and the poi’s show on the world map after i edit the quest_poi and quest_poi_points but the golden arrow you get to point you to the quest doesnt show up on mini map. any idea how to fix this? thanks and i hope i could help out soon with fixes

if I’m not mistaken, this is done by fixing them the proper way, and using the proper dbc reference, somehow.

Well alot of ppl say that this arrow in the mini map is handeld client side which could be right idk lol but its something id like to get working so if anyone got some details plz post it here so we can learn bout it /emoticons/default_tongue.png thanks for help

For reference, you should link to your original topic that was in the wrong forum so people won’t duplicate conversation.

Ok Thanks man will remember that in the future

Hey guys mad a breaktru regrading that yellow arrow in the mini map when you set up a quest’s poi eg:

DELETE FROM quest_poi WHERE questid IN (24767, 24767, 24764, 24765, 24765);

INSERT INTO quest_poi (questid, id, objIndex, mapid, WorldMapAreaId, FloorId, unk3, unk4) VALUES
(24767, 0, 4, 1, 4, 0, 0, 1), – 24767
(24767, 1, -1, 1, 4, 0, 0, 1), – 24767
(24764, 0, -1, 1, 4, 0, 0, 1), – 24764
(24765, 1, -1, 1, 4, 0, 0, 1), – 24765
(24765, 0, 0, 1, 4, 0, 0, 1); – 24765

You notice that map id is as usual 1 for Kalimdor and where worldmapAreaId is i set it to 4 for durotar. now im gna explain why if you type .gps on the chatplane you get the area id of 4865 thats the area id that you would normally use for worldmapareaId. now type in chat plane: /script print (GetCurrentMapAreaID()) which gives me a number of 4 in the chatplane, so i used that in my worldmapAreaId. and now i get a nice lil arrow on my mini map pointing to the quest POI


Quest POI is supposedly from sniffs so I’m not sure how accurate it is to go changing things.

Well this is what worked for me /emoticons/default_biggrin.png try it out i dnt know if itll work for other quests its just the starting area im working on that it worked for for now…