Initial equipment and skills + equipping arrows

Hi all,

I have TrinityCore x64 (rev 812809a977e2) (3.3.5 branch) up and running on my system, with the latest TDB.

I’m a newbie when it comes to WoW at all, so this might be a dumb question, but I couldn’t find any report of this problem anywhere before.

First, the initial skills (Raptor Strike & Auto Shot) won’t work with the equipment you have when you first start with your character, not sure if intended.

After I got a new melee weapon Raptor Strike began to work… The bow is another story though, even though I got a new one, it would say I had no ammo equipped, even though you start with 200 arrows.

I bought another 800 arrows and a new quiver, but it still wouldn’t work… after I removed the arrows from my ammo slot and tried to re-equip it, now it just says that it can’t be equipped.

I tried right-clicking from inside the quiver, tried taking the arrows out of the quiver and right-clicking from inside the bag as well, tried manually moving the arrows to the ammo slot from both quiver and bag too. Nothing seems to work.

Strangely enough, as with the starting stuff (weapons and armor alike), the arrows inside the quiver appear with the “?” icon, while inside the shop they show normally (these are Rough Arrows by the way).

This is a Night Elf Hunter, in case the character class/race matters here. I can also see the “Bow” skill in the character’s skill list.

souns weired, do you have any custom client patches? Did you recreate the char? Is it happening all the time? Maybe also clear cache folder.

No custom patches, clean 3.3.5a client.

Tried deleting the cache folder and creating a new character, issue persists.

mhhh… dbc extracted from that client?
got no other idea, sorry m8

Yes, everything was extracted from the very same client. dbc, maps, vmaps and mmaps.

Would it be possible for you, or somebody else test that on a similar setup?

Edit: Just a small update… after reaching lv10, even though I still couldn’t equip Rough Arrows, it allowed me to equip Sharp Arrows and shoot them.

I don’t want to open a new thread for it, but I think I found a tiny bug:

If you melee hit sitting or laying targets, the crit chance should be 100%. I tried it yesterday and I didn’t critical hit all the time. It is certainly just a little fix in the code… where do I have to look to change it?

I am having the same exact problem. I wonder if the clients we have are somehow broken?

Hi Tommy,

I had the same issue as well and it turned out to be a problem with my client. I threw it out and found a site to download the official Blizzard install files and patches. I ran them all to get the good 3.3.5.12340 version then I re-ran all of the extractors. Then play from the newly installed client and you should be good to go.

/cash

My client was indeed very broken. I noticed a few things at first, like the random name generator missing in the character creation menu and this:

Notice the problem here?

http://i.imgur.com/8gbA8X8.png?2 =http://i.imgur.com/Eso14mj.png?1

Broken Arrows

http://i.imgur.com/GUivRhF.png

Getting a new client fixed everything.

Glad you got it sorted out!

Happy gaming pal,

/cash

Anyway you can link the instructions for that? I am having the same issue here too!

I’m currently using this website’s client download

The broken client I was using was that same one from Eternal WoW. Pretty much any other client download should work.

I’m not real sure of the policies against linking to download sites here so I’ll just say that if you google the version number, you should find a number of spots to get them from. I kept my copies so I could throw them somewhere if ya’ll can’t find them. Let me know if you need me to do so.

/cash

Please do, I am still having some issues with mine :frowning: