Loading menus, guards, & trainers

Using branch 7.2.0 when I login to the server I see that some menus on npcs are not working on some things like trainers and guards, for example when you go to goldshire to the repair vendor or weapon smith it works and pops up just fine but if you go to stormwind and talk to a guard or flying trainer or the repair vendor in stormwind trade district the menu does not pop up, but if you go to northshire most npcs there work just fine and the menus pop up. So I was wondering is there something wrong in the code or is this a database issue or where this issue might be. I only get this problem with 7.2.0 the other ones like 4.3.4 and 3.3.5a work just fine.

This is similar, but known:

https://github.com/TrinityCore/TrinityCore/issues/19527

You have to keep in mind that 7.x is still new and the devs+community are collecting as much data as possible. Even for pre-existing npc’s wil have a different menu, quest, or text than the previous version. The short answer is, don’t compare 335a and master :wink:

Thanks, was just wondering and making sure it wasn’t just me, I am glad to just know it’s acting up thanks

This issue I really don’t think has anything to do with the link you posted but you are right about it being new and something you can’t take to serious about a stable branch. For one thing if you look at the stormwind guard you will see there is nothing to do with the table that you posted for guard entry 68 in creature_template, but I for sure see where you are coming from.

Actually, read what he mentioned. The point is (not the version comparison), but he had an issue with NPCs not spawning and added about npc menus. The creature_template has to do with one of the possibility of npcs not showing up or not defined correctly with the stats for that npc. As for the menus, no that is not the creature_template (obviously), but I then added about the fact that we may not have all the data yet.

I wasn’t saying that creature_template had anything to do with it I was saying it for example using guard 68 entry where if you talk to them nothing shows up I don’t think npc_text has anything to do with the guard not bringing something up. Spawning an npc was his other post he made not this one.

I did gossip fix for Stormwind guards.

What do you mean you fixed it did you repo it yet or is it just on your computer because I don’t see the change in the commit yet unless I overlooked something I could be wrong.

https://github.com/TrinityCore/TrinityCore/commit/6239339069e2390ee3a08cbdc5c5c1d18148407b

Why was the file removed from the sql/old/7/world/folder/filename.sql directory then because when I look the last file is 2017_03_16_03_world.sql but in the commit it says the file name is 2017_03_16_04_world.sql but the file wasn’t removed it is actually in 2017_03_16_03_world.sql so I am taking it that was a typo in the name. Why is the guards not working then if this was suppose to fix them, just wondering, hopefully I missed something.

you need new glasses: https://github.com/TrinityCore/TrinityCore/blob/master/sql/old/7/world/00_2017_04_18/2017_03_16_03_world.sql

https://github.com/TrinityCore/TrinityCore/commit/6239339069e2390ee3a08cbdc5c5c1d18148407b

has for gossips broken maybe 7.2.0 fuckup.

I guess I need new glasses for non working guards too right, they are still not working either way you spin the dice.

" [COLOR=rgb(39,42,52)]has for gossips broken maybe 7.2.0 fuckup. "

I don’t know what commit did it but I noticed you can add an npc now at any high number and the trainers including guards work now when showing up text and options.