MySQL query after fresh compiling

Hey guys,

i wanted to setup a complete fresh core and worked with the wiki Tutorial (not my first TC-Compiling!).

Compiling did work like charm but setting up the DB is probably.

As i said i used fresh data and compiled core. But anytime i start worldserver.exe for creating the new databases i get an permission error.

I already tested to create manually DB’s with the same Login Data as in worldserver.conf and it did work, but anytime im doing it with the worldserver.exe i get the following error.

I already readed many threads where the same error appeared but nothing did help. Could it be that the core itself has a problem, cause 2 or 3 weeks ago there was no problem.

Any ideas out there? (It’s my first time im posting here sorry if i put it in the wrong place)

[ATTACH]1724._xfImport[/ATTACH]

hello,I think you can reload the bases.
Starts well by the Create Base and then to finish the updates

Looks like your mysql user is missing privileges…

from the mysql prompt try:

grant all on dbname.* to ‘user’@‘%’ identified by ‘password’;

change dbname to the name of the database in question, user to the mysql user and password to that user’s password.

What do you mean exactly? Beginning with a new core compiling again or what do you mean with “you can reload bases”. (MySQL TDB_full… i just downloaded this morning)

Will try later and inform you if it worked

Edit:
So tried to fix privileges but didn’t help.

Also startet at point 0 recompiled, sql reinstallation … same problem.

No more ideas anyone?

2 Weeks ago all worked like charm … can’t understand. I will try now with mysql 5.5

Any luck? I’ve got 3.3.5 and 6x running ok with 5.6.28 (linux)

EDIT:

I set up mine like

create user ‘trinity’@‘%’ identified by ‘trinity’;

create database auth;

create database characters;

create database world;

then

grant all on auth.* to ‘trinity’@‘%’ identified by ‘trinity’;

grant all on characters.* to ‘trinity’@‘%’ identified by ‘trinity’;

grant all on world.* to ‘trinity’@‘%’ identified by ‘trinity’;

ran the sql from sql/base

ran the sql from the db download

Sorry for my late response.

No it’s still not working. Did it like you wrote by manually import the sqls but now i get:

“Didn’t find executeable mysql binary at ‘D:/BUILD_TrinityCore/bin/Release’ or in path, correct the path in the *.conf (“Updates.MySqlCLIPath”).”

Only by setting Updates.EnableDatabases = 0 (from 1) it seems to work but is this correct?

did you edit the .conf file and locate the mysql executable?

around line 170 in bnetserver.conf, 225 in worldserver.conf, 158 in authserver.conf

Thanks a lot! Now it’s working again… don’t know why there is not included automatically because in earlier Compilings i did’nt edit these lines. But… who cares. Now it works. THanks a lot again :slight_smile:

Glad to hear!

Those lines are fairly new AFAICT - i think you only need to edit them if the mysql bin folder is NOT in your path, otherwise it won’t find them.