Neues Log System?

Hallo ihr lieben,

ich hab mir heute mal wieder eine neue Core compiliert und dabei festgestellt das ein neues Log System vorhanden ist

Jetzt hab ich das Problem das meine

  • GM.Log (Die pro Account und nicht gemeinsam gespeichert werden sollen)

  • Chat.Log

  • Char.Log

  • Ra.Log

Nicht mehr vorhanden sind also nichts speichern

Kann mir irgendjemand Helfen wie das neue jetzt funktioniert?

Hab es wie folgt eingestellt

[CODE]Appender.Console=1,2,6,

Appender.Server=2,2,7,Server.log,w

Appender.GM=2,2,7,GM.log,w

Appender.SQL=2,2,7,SQL.log

Appender.DBErrors=2,2,7,DBErrors.log

Appender.Char=2,3,7,Char.log,w

Appender.RA=2,2,7,RA.log,w

Appender.Arenas=2,2,7,Arena.log

Appender.SQLDev=2,2,7,SQLDev.log

Appender.SQLDriver=2,2,7,SQLDriver.log

Appender.Warden=2,2,7,Warden.log

Appender.Chat=2,2,7,Chat.log,w

Logger.Root=0,5,Console Server

Logger.Units=1,3,Console Server

Logger.Pets=2,3,Console Server

Logger.Vehicles=3,3,Console Server

Logger.TCSR=4,3,Console Server

Logger.AI=5,3,Console Server

Logger.MapScripts=6,3,Console Server

Logger.NetWork=7,3,Console Server

Logger.Spells=8,3,Console Server

Logger.Achievements=9,3,Console Server

Logger.Conditions=10,3,Console Server

Logger.Pool=11,3,Console Server

Logger.AuctionHouse=12,3,Console Server

Logger.Battlegrounds=13,3,Console Server

Logger.OutdoorPvP=14,3,Console Server

Logger.ChatSystem=15,3,Console Server

Logger.LFG=16,3,Console Server

Logger.Maps=17,3,Console Server

Logger.Player=18,3,Console Server

Logger.PlayerLoading=19,3,Console Server

Logger.PlayerItems=20,3,Console Server

Logger.PlayerSkills=21,3,Console Server

Logger.PlayerChat=22,3,Chat

Logger.Loot=23,3,Console Server

Logger.Guilds=24,3,Console Server

Logger.Transports=25,3,Console Server

Logger.SQL=26,2,Console Server SQL

Logger.GM=27,3,Console Server GM

Logger.RA=28,3,RA

Logger.Warden=29,3,Warden

Logger.Authserver=30,3,Console Server

Logger.Worldserver=31,3,Console Server

Logger.GameEvents=32,3,Console Server

Logger.Calendar=33,3,Console Server

Logger.Character=34,3,Char

Logger.Arenas=35,3,Arenas

Logger.SQLDriver=36,5,SQLDriver

Logger.SQLDev=37,3,SQLDev

Appenders=Console Server

Loggers=Root[/CODE]

Bedanke mich jetzt schon einmal für eure Hilfe

Ich habe die log dateien selbst erstellen müssen wo ich sie in der Config angebenen habe.,und dann die rechte auf 0777 gestellt.

Ich habs auf einem Linux root laufen.

Hoffe ich konnte dir helfen.

Ich benutz leider windows und versteh leider gerade nicht so genau wie du das mit 0777 meinst

CHMOD 0777 bedeutet dass Eigentümer, Gruppe und Welt das Objekt Lesen, Schreiben und Ausführen können. Halte ich bei sowas nicht für ratsam. Unter Windows ist das hinfällig, stelle nur sicher, dass das Verzeichnis nicht schreibgeschützt ist oder so.

Was die Konfiguration angeht…da sind schlauere Köpfe von TC noch am eruieren, wie das so funktionieren soll, insbesondere, da die Dokumentation bisher recht rudimentär ist.

Also wenn ich das richtig Verstanden habe, haben Sie ein neues Log System eingeführt das aber noch nichts Logt und wir müssen noch warten bis die das ausgetüftelt haben bis es meine Logs wieder speichert?

  • GM.Log (Die pro Account und nicht gemeinsam gespeichert werden sollen)

Appender.GM=2,2,7,GM_%u.log,w

  • Chat.Log- Char.Log
  • Ra.Log

Nicht mehr vorhanden sind also nichts speichern

Appenders=Console Server Chat Char GM Ra

Loggers=Root Server Chat Char GM Ra

Die Logs funktionieren schon, aber es gibt halt noch keine Dokumentation dazu (außer das bisschen was im Commit selbst steht).

So sollte das aber erstmal funktionieren, bisschen probieren und testen ist derzeit angesagt.

Von dem CHMOD 0777 würde ich absehen.

Schon mal vielen vielen Dank

Also er Erstellt jetzt die Dokumente von Alleine aber er speichert darin nichts und spuckt in der Console folgenden Fehler aus

Log::CreateLoggerFromConfig: Wrong configuration für logger Chat. Config line:

Sind alle Datein leer oder speichert er mittlerweile zB GM Befehle?

Beim Chat musste halt schaun, Grund steht ja dabei “Wrong configuration für logger Chat”.

Warum auch immer man den Chat loggt.

Die Datein sind leer

Server und GM Befehle macht er jetzt Einwandfrei

Die sind jetzt wie folgt

Appender.Server=2,3,7,Server.log,w

Appender.GM=2,3,7,GM_%u.log,a

Die Char, Chat und RA speichert er nicht, die sind wie folgt

Appender.Char=2,3,7,Char.log,a

Appender.RA=2,3,7,RA.log,a

Appender.Chat=2,3,7,Chat.log,a

Logger.Character=34,3,Char → Logger.Character=34,2,Char (If you want to save Player dump on delete)

Appenders=Console Server Chat Char GM Ra

Appenders=Console Server ChatSystem Character GM RA

Musst mal versuchen.

Leider nein ausser das er jetzt nicht nur den Fehler mit [FONT=helvetica]Logger bringt sondern auch noch mit [/FONT][FONT=helvetica]Appender passiert leider nichts[/FONT]

http://pastebin.com/KdSgZ6t5

Das hat jetzt super funktioniert, jetzt speichert er alles bis auf das ChatSystem was kann daran noch der Fehler sein?

So if you use settings what Aokromes linked, then add chat for both in the end, that would look:

Appenders=Console Server DBErrors Warden Arenas Char GM Chat
Loggers=Root Warden Arenas Character GM SQL PlayerChat

and change these to:

Logger.PlayerChat=22,2,Chat Appender.Chat=2,1,15,Chat.log

To test i enabled:

ChatLogs.Public = 1
ChatLogs.Whisper = 1

and result:

2012-08-15_16:50:30 DEBUG [PLAYER_CHATLOG ] [WHISPER] Player Mepaladin tells Kirby: test this bjksdbfkl
2012-08-15_16:50:38 DEBUG [PLAYER_CHATLOG ] [WHISPER] Player Kirby tells Mepaladin: pashol nahuj
2012-08-15_16:53:21 DEBUG [PLAYER_CHATLOG ] [SAY] Player Mepaladin says (language 1): paramparam

Faq

Super vielen vielen vielen Dank an euch alle, jetzt Loggt er wieder alles einwandfrei /emoticons/default_smile.png

Der request ist zwar erledigt, aber ich lass das mal für die Zukunft offen, falls jemand Fragen zum gleichen Thema hat.

Jetzt wurde das System wieder einmal umgeschrieben Haare ausreiß und jetzt funktioniert auch alles aber der speichert mal wieder keine Chats egal ob ich die alten Einstellungen benutze oder die Neuen, kann mir jemand weiter helfen?

Appender.Console=1,3,0Appender.Server=2,2,0,Server.log,w

Appender.GM=2,2,0,GM_%s.log

Appender.DBErrors=2,2,0,DBErrors.log

Appender.Char=2,2,0,Char.log,

Appender.RA=2,2,0,RA.log

Appender.Warden=2,4,0,Warden.log

Appender.Chat=2,2,0,Chat.log

Appender.CharDump=2,2,0,%s.log

Appender.Arenas=2,2,0,Arena.log

Appender.SQLDev=2,2,0,SQLDev.log

Appender.SQLDriver=2,2,0,SQLDriver.log

Appenders=Console Server GM DBErrors Char RA Warden Chat

Logger.Root=0,5,Console Server

Logger.Chat=15,3,Chat

Logger.DBErrors=26,5,Console Server DBErrors

Logger.GM=27,3,GM

Logger.RA=28,3,RA

Logger.Warden=29,4,Warden

Logger.Worldserver=31,3,Console Server

Logger.Character=34,3,Char

Logger.Arenas=35,3,Arenas

Logger.SQLDriver=36,5,SQLDriver

Logger.SQLDev=37,3,SQLDev

Logger.CharDump=38,3,CharDump

Logger.Load=40,3,Console Server

Logger.Opcodes=41,6,Console Server

Loggers=Root Chat DBErrors GM RA Warden Character Load WorldServer Opcodes

Was wurde denn da geändert, außer das aus einer 2 eine 3 wurde? ^^

DIe Struktur is ganz anders wenn man das alte und neue vergleicht

Da hat es doch noch funktioniert?