NPC Spawn

Hi Leute,

ich hab seid Heute ein Problem mir dem Spawen von NPCs.

Ich stell sie hin mit .npc add … aber die erscheinen nicht in der Tabelle creature und nach nem restart sind die auch wieder weg.

Objekte kann ich ohne probleme hinstellen nur die NPCs spacken rum.

Kann mir da jemand helfen?.

THX

Bist du sicher, dass du nicht .npc add temp oder .npc add t oder sowas benutzt?

Wenn du sie gespawnt hast, was gibt dir .npc info für ne GUID aus?

Jo bin sicher das es .npc add ist und mit dem GM Helper ist es ja das selbe Prob.

Hier mal der NPC info text vom NPC mit der ID 37582

Schau die mal die angegebene ID an.

Das hatte er aber schon bevor das Problem auftrat.

[00:53:52] Spieler hat NPC angewählt

[00:53:52] GUID: 749848.

[00:53:52] Faction: 749849.

[00:53:52] npcFlags: 1770.

[00:53:52] Entry: 2.

[00:53:52] DisplayID: 37582 (Native: 30685).

[00:53:52] Level: 80.

[00:53:52] Leben (Basis): 100800. (max): 100800. (aktuell): 100800.

[00:53:52] Field Flags: 32832.

[00:53:52] Dynamic Flags: 8.

[00:53:52] Faction Template: 1770.

[00:53:52] SpawnTime: Gesamt:5m Verbleibend:0s

[00:53:52] Loot: 0 Taschendiebstahl: 0 Kürschnerei: 0

[00:53:52] InstanceID: 1

[00:53:52] Phasemask: 1

[00:53:52] Rüstung: 7822

[00:53:52] Position: 5263.232910 1675.912354 784.300842.

GUID ist gegeben (= kein Tempspawn). Wenn er den nicht saved müsstest du nen Fehler in der SQL-Log haben (SQL-Log in der Config einschalten falls nicht schon geschehen)

ich vermute mal random laufen und keine distance eingegeben…bei mir wurden solche npc nicht gespawned

im log sollte dann ein fehler drin steht der in etwa so aussieht:

ERROR: Table `creature` have creature (GUID: 39646 Entry: 3197) with `MovementType`=1 (random movement) but with `spawndist`=0, replace by idle movement type (0).

nur halt eben mit der guid/entry deines npc’s

gruß vardash

hier die Log Datei.

Hab nix in der Art gefunden und die ID 37582 (der gespawnte NPC) kommt auch nicht drin vor.

DOWNLOAD NOW!

Danke für eure Antworten, ich hau mich nun auf Ohr.

GN8 @ all

soweit ich das sehe ist das ein instanz mob…wolltest du ihn in der instanz spawnen ?

falls ja

hier mal die spawnpoints aus meiner db:

[CODE]DELETE FROM creature WHERE id=37582;

INSERT INTO creature (guid,id,map,spawnMask,phaseMask,modelid,equipment_id,position_x,position_y,position_z,orientation,spawntimesecs,spawndist,currentwaypoint,curhealth,curmana,DeathState,MovementType) VALUES

(92102, 37582, 632, 3, 128, 0, 0, 4902.95, 2212.7, 638.734, 6.04948, 7200, 0, 0, 60480, 176280, 0, 0),

(124334, 37582, 658, 3, 128, 0, 0, 441.213, 215.893, 528.71, 6.1897, 7200, 0, 0, 60480, 176280, 0, 0),

(123585, 37582, 658, 3, 128, 0, 0, 1079.01, 205.893, 628.156, 3.63306, 7200, 0, 0, 60480, 176280, 0, 0);[/CODE]

aber mal ot…alterschwede…hast du viele errors in deiner db /emoticons/default_smile.png

gruß vardash

Moin,

Ich wollte den in HDR spawnen. Funzt aber bei anderen NPCs auch nicht.

Hab noch die alte DB wo er gespawnt war hab dort die daten rausgeolt.

Mit den ganzen Errors, naja bin erst seid Januar mit meinem eigen projekt dran, hab Früh und Mittagschicht und habmir seid Januar alles soweit selbst bei gebracht. Die errors bekomm ich auch noch raus^^.

Ich spiel einfach mal das Backup vom WE auf mal sehen ob dann der Fehler weg ist, vielleicht hab ich was zerschossen /emoticons/default_sad.png

Danke euch für eure Hilfe

Gruß Pig

Dein Problem was ich denke war bei mir auch so du hast die Updates nicht eingebatcht, deshalb kommt bei dir bestimmt auch ein error im Worldserver wenn du was spawnst. Versuchs einfach mal!

Nee nee, die Updates hab ich alle drin.

Einige Errors kommen von den Custom zeugs was ich drin hab wie Item und NPCs.

Und sonst muss ich ma schauen das ich se raus bekomme. Sollte ja nicht so schwer sein.

Gruß Piggy