[Patch] Halls of Reflections

I’ve been having some issues with HoR scripting. I have the first room with Falric, and Marwyn working great, the second area with Frostworn General works great, and his death properly triggers the Lich King and jaina/sylvana’s fight scene for the next room.

This is where I"m hitting a wall; -No pun intended. jaina/sylvana will start the escort part breaking through the icewalls, but no mobs spawn, and Lich King stays in place frozen.

Here is what I"m working with so far…

I think it’s a problem with ‘boss_the_lich_king_hor.cpp’ but I can’t see the problem.

Scripts- Frozen Halls - Halls of Reflection

instance_halls_of_reflection.cpp

halls_of_reflection.h

halls_of_reflection.cpp

boss_the_lich_king_hor.cpp

boss_marwyn.cpp

boss_falric.cpp

SQL

Hor.SQL

I’m on trinity commit cb8fc503ddb1fc87abdd1c88146646c68aea46b9 (09.28.12)

Everything compiles fine for me, runs fine up to the point mentioned above. I double checked the Npc’s and made sure they had their scripts in place, and if needed EventIA enabled.

Any help is much appreciated. I’m hoping I just made a dumb mistake somewhere. /emoticons/default_sad.png

– Update – Added a new patch for what I have gotten so far. Thanks again all.

Hortest2.patch

Well if you want you can use this almost completed version of HoR maded by someone experienced (dont remember name so i cannot give credits /emoticons/default_sad.png )

http://pastebin.com/79VAMCAh

http://pastebin.com/Suu1JA8U

http://pastebin.com/Hzp6FuHD

http://pastebin.com/wqEbEiZX

http://pastebin.com/R7DCfuR0

it needs only some minor fixes:

  1. Trigger function that will put some collision on the door that opens when LK enters the room and when he goes out from the room since the players can simply skip the 1st events…

  2. Scripting of Jaina/Sylvanas battle with LK untill you reach them after Frostworn General.

  3. When LK Start casting on Jaina/Sylvanas at the end of the road,a gunship shows up for 1 sec from nothing and start shooting instead of flying from above and start shooting.

Good luck and tell me if you have problems with the implementation /emoticons/default_smile.png

Thanks Razhael. Very generous of you to share your code. Unfortunately, I still have the same problem with the Lich King 37226; after the mock fight with Jaina/Sylvanas He just stays there frozen in place while Jaina/Sylvanas run out and breaks ice walls. No waves of mobs start. I"m starting to thing that it must be something set wrong on that npc, or the ones linked in the script…the adominations, witch doctors, gouls etc. Looking into it a bit more to try to find out. /emoticons/default_sad.png

Reset your files from “srcserverscriptsNorthrendIcecrownCitadel” and put those from the master branch.

Reset your database (i hope you have backups of all your customizations).

Once you are done.Do the change with my files and execute the sql it contains the right events and creature stats.

After i finish some more importan things i will finish this with the effects and the collision.

Tried that. /emoticons/default_sad.png It actually sent me backwards a little. Now on the last leg of the instance, I"m stuck at the first Icewall. LK still stuck with Aura Dark Bindings.

added some minion bots in to make a quick video

Around 7 min mark is the relevant part…

Last bit at the end is just boredom, but it should give ya an idea of what I"m stuck on. It’s strange. Must be DB side if the script is working fine for you, but can’t seem to track it down. /emoticons/default_sad.png I’ve tried a fresh DB, tried with my old DB - that gets me to the end, but same problem with LK stuck in that room doing notta.

Ok this is kinda strange,i am using the same files and everything is normal at me,when i reach sylvanas/jaina on the 1st wall he debuff from the holding spell and start walking to us and spawning waves of undeads…

also i am allways using it on an clean TDB so no more modify is needed >.<

try to find, why he do not more.

add some debug messages to the script, so u can find out, at which point it stop working.

now u can try to fix it.

My guess is that the npc flag of the lich king in your db has incorrect values, cause im not sure he should be attacable or respond to nearby aggro threats that’s why he breaks the script.

Well those are my two cents.

Btw I just recompiled to test these scripts too, everything compiles fine, imported SQL but after the Lich king moves inside the room and Jaina follows him the wave of mobs never starts, any could what could be the problem?

HDR is the most [FONT=helvetica]strange instance i think ^^[/FONT]

Thanks all for the interest. I’m still looking into it. Been busy setting up a new dedi. I think it must be a DB flag as mentioned. Gonna start from scratch with a fresh compile and DB again, and go from there. I"ll update here with any findings.

I have fully completed script with working lich king … all working /emoticons/default_biggrin.png i can post here

Please… Do it! /emoticons/default_rolleyes.gif

That’d be great. If it’s a DB issue on my side, it may not necessarily help my particular issue, but I"m sure there are plenty of people out there that could use it, and would really appreciate it. Eventually I’ll figure out what’s wrong with my stuck npc, and would much appreciate a nice patch like that as well.

Lich king stuck ? … You have boss_the_lichk_king_hor.cpp compiled and added in cmake ? … Have lich king scriptname ?

Yes. Script was added properly in Cmake, compiled, and Npc has proper Scriptname in place.

Do you have the boss_lich_king_hor script added in your ScriptLoader.cpp?

Yes. and when I get npcinfo, it says Script running is boss_lich_king_hor /emoticons/default_sad.png

lol i have found you error HAHAHAHA your gunna laugh, at the bottom of your script change void AddSC_boss_lich_king_hr() to void AddSC_boss_lich_king_hor() how couldnt you see it XD

on a single .patch file

hortest.rar

Unfortunately that doesn’t change anything. Still stuck with Dark Binding. It’s gotta be one of his flags, which is strange because I wiped my DB pulled a fresh one. TDB_full_335.49_2012_09_16 Then applied updates, and ran the SQL. I’ve been changing the flags around a little, but they don’t seem to have an effect.

He is currently setup like so…


/*

SQLyog Ultimate v8.55

MySQL - 5.5.28

*********************************************************************

*/

/*!40101 SET NAMES utf8 */;

insert into `creature_template` (`entry`, `difficulty_entry_1`, `difficulty_entry_2`, `difficulty_entry_3`, `KillCredit1`, `KillCredit2`, `modelid1`, `modelid2`, `modelid3`, `modelid4`, `name`, `subname`, `IconName`, `gossip_menu_id`, `minlevel`, `maxlevel`, `exp`, `faction_A`, `faction_H`, `npcflag`, `speed_walk`, `speed_run`, `scale`, `rank`, `mindmg`, `maxdmg`, `dmgschool`, `attackpower`, `dmg_multiplier`, `baseattacktime`, `rangeattacktime`, `unit_class`, `unit_flags`, `unit_flags2`, `dynamicflags`, `family`, `trainer_type`, `trainer_spell`, `trainer_class`, `trainer_race`, `minrangedmg`, `maxrangedmg`, `rangedattackpower`, `type`, `type_flags`, `lootid`, `pickpocketloot`, `skinloot`, `resistance1`, `resistance2`, `resistance3`, `resistance4`, `resistance5`, `resistance6`, `spell1`, `spell2`, `spell3`, `spell4`, `spell5`, `spell6`, `spell7`, `spell8`, `PetSpellDataId`, `VehicleId`, `mingold`, `maxgold`, `AIName`, `MovementType`, `InhabitType`, `HoverHeight`, `Health_mod`, `Mana_mod`, `Armor_mod`, `RacialLeader`, `questItem1`, `questItem2`, `questItem3`, `questItem4`, `questItem5`, `questItem6`, `movementId`, `RegenHealth`, `equipment_id`, `mechanic_immune_mask`, `flags_extra`, `ScriptName`, `WDBVerified`) values('37226','0','0','0','0','0','30721','0','0','0','The Lich King','','','0','83','83','2','2102','2102','0','1.8','2','1','3','509','683','0','805','35','2000','0','1','768','2048','8','0','0','0','0','0','371','535','135','6','36','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','0','','0','3','1','2000','500','1','0','0','0','0','0','0','0','151','1','0','617299955','0','boss_lich_king_hor','12340');

Thank for putting all together in a patch. /emoticons/default_smile.png This will be excellent soon as I can figure out why my Lich King is stuck.