[Patch] VAS AutoBalance [Updated as of 9-3-2012]

Alright, this is in continuation of an older thread, [/URL][URL=“/”]http://www.trinityco…as-autobalance/

Coder by the name hkarta is working on VAS Autobalance, a mod which allows instances to be scaled to the number of players within it. This allows for single player or play on dungeons/raids/instances where it was not originally allowed. Currently it modifies the amount of damage and health of mobs in instances, it doesn’t address DOTs as of yet and it will never address fights that are scripted to require more than an X number of players. That said although I am a coder, I am not maintaining hkarta’s code beyond making sure it will compile cleanly and that it works with the current revision of Trinity Core.

Below is attached the current Patch to VAS Autobalance, it will patch against an unpatched copy of Trinity Core if you have any other mods to apply after this one or before this one you’ll have to manually make the corrections to the patch yourself.

Updated: Dots, Summoned Mobs, and Mob Pets have been addressed and should be working. Dot scaling has yet to be fully tested but in the instances I’ve used it in works just fine. Any mobs that are called into the instance after the instance has started should be scaled as well. Although it is compatible I’m not going to update the patches to be directly applicable with AHbot, you’ll have to make manual corrections to the patch.

VAS_Autobalance-8_7_2012.patch

VAS_Autobalance-8_16_2012.patch

VAS_Autobalance-8_30_2012.patch

VAS_Autobalance-9_3_2012.patch

I can confirm that yes the patch above is fully working… although not tested in heroics or 25 mans… I am only doing this on a dev box have no other players

In order to install it I must place the file you linked in the Trinity’s source code folder and build with cmake?^^

In order to use it, you use git apply in the root folder for the trinitycore then build using cmake… For Visual Studio follow the same instructions in the wiki for building trinitycore after patching.

Since we just got our butts kicked in a 5-man instance on our heavily populated server with 3 people online at once I’m trying this. Hopefully it will ease my suffering. /emoticons/default_smile.png

Some warnings.

[CODE]

$ git apply VASAutoBalance.patch

VASAutoBalance.patch:220: trailing whitespace.

sLog->outString(" Powered by {VAS} Script Hooks v%4.2f",VAS_Script_Hook_Ver

sion);

VASAutoBalance.patch:322: trailing whitespace.

VASAutoBalance.patch:348: trailing whitespace.

VASAutoBalance.patch:374: trailing whitespace.

VASAutoBalance.patch:589: trailing whitespace.

#define BOOL_TO_STRING( ((? “true”:“false”)

warning: src/server/game/Entities/Creature/Creature.cpp has type 100644, expecte

d 100755

warning: src/server/game/Entities/Unit/Unit.cpp has type 100644, expected 100755

warning: src/server/game/Scripting/ScriptLoader.cpp has type 100644, expected 10

0755

warning: src/server/game/Scripting/ScriptMgr.cpp has type 100644, expected 10075

5

warning: src/server/game/Scripting/ScriptMgr.h has type 100644, expected 100755

warning: src/server/game/World/World.cpp has type 100644, expected 100755

warning: src/server/game/World/World.h has type 100644, expected 100755

warning: squelched 96 whitespace errors

warning: 101 lines add whitespace errors.

[/code][/CODE]

I fixed most of the whitespace errors with Notepad++. The real problem is I can’t apply AHbot patch before or after this without AHbot patch failing or VAS failing. /emoticons/default_sad.png

I can’t live without AHbot, or more accurately my wife will make me miserable if AHbot doesn’t work. /emoticons/default_tongue.png

I close older thread and put new version on this thread in order to allow cvmagic to edit 1st post to avoid the need of search new versions on the whole thread.

I wanted to extract the maps myself but I can’t find the .sh script in the contrib folder mentioned in the mmaps thread.

I just found the repo and pulled the source for mmaps to get the tools. Extracting now.

I’ve never been able to get the extractor to work without crashing, so I’ve been using that mmap archive for a while. If you wouldn’t mind uploading your copy once you’re done I’d be more than grateful.

Crashes trying to extract for me also. I build 64 bit Windows versions and use 64 bit DLL’s from MySQL also. I tried with the extractors downloaded with the source and the ones created when I compiled and they always crash. Tried DLL’s created when compiled and the ones included with the source tools and it crashes for me either way. I wonder if opening a git bash window isn’t getting the needed file system rights needed or something? Not sure how to run that as admin since it’s different from a regular command prompt or even if that has anything to do with it. Nearly 2:00 AM and I’m giving up for the night.

It crashes in linux too, with a buffer overflow error, it’s very likely a bug in the code that needs to be fixed. I’m not too sure who’s actively working on mmaps and it’s utilities but it’d be worth while contacting them.

I give up. Transmogrification is messing me up. There is no config option to disable it which is mildly annoying. I imported the SQL files to enable it but I’m still getting errors so the server won’t start. This is exactly why I don’t like trying new patches. I’ve wasted many hours and accomplished nothing. I’m reverting my server to backups. It’s bad enough dealing with one patch but add a second one and it’s just a constant pain in the ass. Not your fault but it frustrates me.

This is why some of these things would work better as official parts of the main core that you could enable or disable in the config files. Doesn’t work, turn it off, want to use it just enable it in the config. For people that like to mess with this stuff great, for the rest of us it’s all a great big time sucking hole that often ends in frustration.

Well, to disable Transmogrification it’s as simple as remove the npcs for it from ingame.

Nothing simple about it. Yeah if you have it set up and working you can just disable the NPC. I had it compiled in and couldn’t get it working because it seemed I was missing some SQL after importing all the ones the readme said I needed.

[FONT=helvetica]MMAPS (Optional): [/FONT][/URL][URL=“/mmaps.rar”]http://www.filehosti…56615/mmaps.rar

Link dead…

Does this really add mmaps to Trinitycore that are functional ?

To address Zaranthos’ issues with the other mods I am going to remove all the mods with exception to ahbot and VAS off the prepatched file. If you want to use Transmogrification make sure to grab it from its thread([/URL][URL=“/”]http://www.trinityco…ification-335a/)

The mmaps that was patched in seemed functional, the file I had linked was the pre-processsed files needed to make mmaps work. Which may be where Zaranthos stumbled, you have to explicitly disable it in the configuration if you dont have the mmap files in place otherwise it can crash the server. Seeing that I’m removing those patches off my prepatched trinity core I may not have to renew that link, although I do need to find out why that link is dead.

Edit: It’s just a bad hosting service… they didn’t take it down for legal reasons their permissions are broken to download any file.

I had mmaps files in place. The specific errors I was getting were related to Transmogrification. Honestly I just reached the end of my patience with it and gave up. I can’t spend a lot of time every time I want to update my core. I’d love to try different things but I just don’t have the time to fight with incompatibilities.

I’m also not sure mmaps files alone are enough. I was using my previous vmaps and maps files but the mmaps thread seems to indicate they all need to be extracted again for mmaps.

If this patch plays nice with AHbot I’ll probably try it again. It would make the game a lot more fun on the small servers.

Thanks for all the work on the patch and trying to help me. I know it can be frustrating at both ends. /emoticons/default_smile.png

Don’t worry about it, and yes with mmaps you do need to reextract your VMAPS…

Pulled source, applied AHbot.patch, applied VASAutoBalance.patch, continued to build as normal. Success! /emoticons/default_biggrin.png

Looking forward to testing this extensively. If I find any problems I’ll let you know. Thanks!

Could someone with the latest version (or close) check this to see if this is a Trinity bug or VAS bug? [/URL][URL=“https://github.com/TrinityCore/TrinityCore/issues/7019”]Issue #7019: [Quest] What Do You Feed a Yeti, Anyway? · TrinityCore/TrinityCore · GitHub

Enable VAS Debug to level 3, fight the same mobs and see if it reports anything about those mobs in the server’s console. If so it might be a VAS issue. Although it’s not supposed to hook into any non-instance mobs