Remove gap where XP bar was

Hello everyone, I’ve made a 3.3.5 server where I want the max character level to be 30. I’ve gotten that set, but the UI is still displaying that it thinks there should be an XP bar. I enabled tracking of a Reputation to make it more clear what I mean.

I’ve tried changing DEFAULT_MAX_LEVEL = 30 and MAX_LEVEL = 30 in DBCEnums.h and recompiled, but that didn’t work.

If you have any ideas please let me know, and thank you for having me here.

[ATTACH]2029._xfImport[/ATTACH]

Works fine for me…

Did you set MaxPlayerLevel = 30 in your worldserver.conf ?

Yes, MaxPlayerLevel and StartPlayerLevel are both set to 30.

I’m not sure, I don’t see that gap. This seems more of a client issue really.

That’d make sense. So you also have a server where the max level is less than 80 and you don’t have that gap eh?

I just modified my conf on my test server to max level 30, created a new character, maxed him to level 30, added reputation status where the xp bar would go and I dont see the gap. Same goes for characters less than level 30 where they don’t have the reputation status bar. That gap never shows.

[COLOR=rgb(0,0,0)]¯_(ツ)_/¯

Hmm, well I’ll keep digging then. Thanks.

Edit: this was bothering my OCD so I changed the MaxPlayerLevel to 31, turned off all XP gains and made the XP requirement for 30-31 be 999 XP. Much nicer on my eyes. :smiley: