Ridiculous Issues

So for the past 4 hours I’ve been following this guide https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130077/Installation+Guide step by step. And every single step I run into an issue that hasn’t been accounted for that I have to google to fix myself.

For example, in step 3 of the Windows Requirements I was directed to install the MySQL Server Community Edition. At first this worked well until I run into the step "During MySQL Configuration, near the end of the installation process, create the user trinity with password trinity". Well no matter how many different ways I went through both the setup and the install wizard, there was never an option to create any profile. The closest I could find were either setting up my root password or just using an anonymous account, which did not allow me to change anything regarding the username or password of any “profile”. So I simply skipped that step and found my own way around it to make it work.

Second Issue. In Step 1 of the Windows Core Installation, I was told to make a directory in my C drive called Trinity. I right clicked on this folder and opened up GitExtensions to get the source files. Well it turns out by doing this, it created another subfolder. There is no option to make it not create the subfolder as I found out later down the line in the instructions (that didn’t include that fact). Multiple times you are directed to use the Trinity file in your C drive to reference files various applications need to find. I had to Google around and manually go into this folder and change all the coming directories to point at this new subfolder instead of the one this guide told me to.

Third Issue. Step #1 through #9 show how to use CMake to configure and generate the source files downloaded through GitExtensions. I follow every step word by word all the way through and double check. I click on configure and boom, full of errors. I did exactly what I was told to do and CMake couldn’t for the life of it figure out where the libraries were from Boost. So of course I had to go in manually for like an hour of google searches to fix the problem. Turns out this flawless application can’t find the folder full of 2 gigs of libraries to I had to move them all to the main folder with the exes and such, and then redirect CMake to look there for the libraries.

Then comes another CMake issue. It doesn’t recognize that I have OpenSSL installed and can’t find it. Again, knowing very little about how this works I have to leave the guide and go on another half an hour of google searches to figure it out. At this point I can’t even remember what I did to actually make it work.

And oh boy I bet you weren’t expecting another issue. I finally manage to get everything configured and generated, and I open my project from CMake into Visual Studio 15 2017 Win64 (which I was instructed to do by the guide). Well I follow every direction to the word, and after sitting there for 20 minutes building the files, it gives me 7 errors about more files the thing can’t find.

This entire guide is so convoluted and incorrect that I am more than over with trying to make this work because even after some more intensive Google searches into the error, I cant find any answers to my issue. I really don’t feel like troubleshooting with myself for the next 3 hours constantly building the files over and over and failing seeing if what I did fixed the issue. Because apparently its very difficult to tell people what to click on and where to drag the files to make it work. gg

Erg…it isnt so difficult man…

Here you have a Spanish video-Guide

While the guide isnt perfect, it still captures the most important parts and is good enough for the job.

Some of the issues you listed sound like user errors.

[ol][li]You are clearly presented a way to create a new user in the mysql installer. If you did not have this view, then you are possibly using some other way of installing MySQL that was unexpected or the installer may have changed over time. https://i.imgur.com/ceQRzfk.png https://i.imgur.com/81Rq8Lz.png[/li]
[li]You are clearly instructed to leave the subdirectory field empty. Then it will not create a subdirectory. Seems you missed this? https://i.imgur.com/XgRZZjT.png[/li]
[li]The issue was possibly that you had the wrong boost version installed (did not use the provided links to download or accidentally downloaded wrong version) or that you did not restart CMake between attempting to do things like installing boost and configuring - which is mentioned in the guide. It is also possible that the system variables require a relog in windows or restarting the whole machine to take effect - this is not mentioned in the guide. Without the errors and the state of the machine it is hard to tell afterwards what your issue was.[/li]
[li]It is possible you installed wrong version of openssl accidentally. Unsure if some unconventional location may also be a reason.[/li]
[li]Most dependency errors during compile I have seen are caused by users installing wrong dependencies. For example 32 bit library when they compile 64 bit. This mostly happens for MySQL and Boost. Another problem has been the new boost and visual studio versions that required the boost finding script to be changed, but I have not checked if that was corrected already - it may have required some manual fixing.[/li]
For the issues that you somehow solved it would require seeing the errors and possibly what you have installed and how you have set up the environment to figure out. This is why it is hard to imagine what could have been wrong. Even a small mistake can lead to nothing working and it could be that your system is different in some way from the majority of other systems (new versions of software etc.). So if you cannot solve the problems you should post the error messages and environment data, like what bit version you are compiling, and ask for help.

In case you are getting errors there is also a troubleshooting section that has some guides for handling specific errors you may encounter: https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130044/Troubleshooting+articles
In the beginning the guide encourages you to search the forums and ask for help if you cannot find what you need. - There is even a support channel you can ask help live on irc.

Anyone is free to edit the wiki, which means that after figuring out what is missing from the guide you can add it in.

That being said this software is probably not being built for the average joe to use. Some knowledge about the used software and programming as well as problem solving is likely expected.
It should also be expected that a new user will have problems configuring a project of this size and with this many dependencies - even with a perfect guide.
New issues keep rising all the time as used libraries and software is being developed by third parties as well as TC.

@SouthSideDown Just give the community a bit of patience. We are to help. I personally will still help even if you rant on the forums. But as Rochet2 mentioned, ask us in IRC if you need a more immediate response and we can also help with some of the steps (even if the wiki is not detailed with beginners experience on compiling a program)