Running 3.3.5. Testing Shattered Sun area and getting attacked by invisible Wretched Devourer and Wretched Fiends. How to turn them back to visible?

As title suggested, was running around at the Shattered Sun area and trying to do a quest called Arm the Wards!. It require the killing of Wretched Fiend and Wretched Devourers. Unfortunately they’re invisible and when I run around the area, they will attack me but I can’t see them but I could attack back as long as I’m pointed toward the npc’s direction. Was reading up on Creature_Template in the wiki but could not find the right entry to edit. What control whether a npc is visible or not? Unit_flags or Unit_flag2 and what is the value for it?

Thanks for any assistance.

What reversion are you using? I don’t seem to have that problem.

It’s from an revision a few days back… TrinityCore rev. aa6cd460eecb 2017-05-29 20:12:11 -0300 (3.3.5 branch) (Win64, Release, Static) (worldserver-daemon) ready…

I guess I can update to the latest version and see if that makes a different.

So here are the details. For the creature_template tags. (335a)

https://trinitycore.atlassian.net/wiki/display/tc/creature_template#creature_template-unit_flags

https://trinitycore.atlassian.net/wiki/display/tc/creature_template#creature_template-unit_flags2

However, I havnt found any issues to that specific quest. (Assuming it’s a quest issue) Not sure if that quest triggers the NPCs to become invisible or the NPCs in that area are just bugged. If it’s a quest issue, then it’s possible that there is a trigger, rather than a db issue.

Anyhow, I will try that quest when I get home. In the meantime, try searching if there are others that have identified that bug. If you can’t find any issues open, please feel to create one :slight_smile:

(sounds like an easy fix)

reference for my search:

https://github.com/TrinityCore/TrinityCore/issues?utf8=✓&q=Wretched

I checked WowHead and make sure the displayid on both npcs are correct. I thought they might have their modelid wrong but that is not the case. Here is the quest from WowHead. http://www.wowhead.com/quest=11523/arm-the-wards#comments

Apparently I have to loot something from the dead npcs in order to finish the quest and since they’re not visible, I can’t loot it. Tried as I might, I checked on both unit_flags and unit_flags2’s flag descriptions but could not find anything that makes reference to being invisible. Guess I’m at a lost.

Tried with the most recent version TrinityCore rev. 1841752acb00 2017-06-05 01:36:04 +0200 (3.3.5 branch) (Win64, Release, Static) (worldserver-daemon).

Thanks for any other suggestion.