SOAP Issues Trinity Core 3.3.5a

Operating System: Windows 10

[COLOR=rgb(51,51,51)]Here’s what I did:[COLOR=rgb(51,51,51)]Enabled SOAP & Ra[COLOR=rgb(51,51,51)]Downloaded PuTTy.exe as a Telnet source.[COLOR=rgb(51,51,51)]Port forwarded 7878[COLOR=rgb(51,51,51)]Port Forwarded 3443[COLOR=rgb(51,51,51)]Tried Telnetting to 7878, DOES NOT CONNECT - attempts but closes immediately when it tries to.[COLOR=rgb(51,51,51)]Tried Telnetting to 3443 CONNECTS no issues.[COLOR=rgb(51,51,51)]Setting up Azer-Cms OR MangosWeb, using Ra does NOT connect to the server and fails delivery on web shop items.[COLOR=rgb(51,51,51)]Setting up Both on SOAP and it still does not connect.[COLOR=rgb(51,51,51)]Soap is ALSO enabled on Webhost.[COLOR=rgb(51,51,51)]SOAP is binding on 0.0.0.0[COLOR=rgb(51,51,51)]RA is binding on 0.0.0.0

1st thing. We don’t support repacks or other sources outside of TC.

Have the machine bind on the actual IP. or try 127.0.0.1

RA Port is not the same as SOAP. so you can throw out 3443. Just worry about HOW you are connecting to 7878

If your server is something like 192.168.1.20 ← then use that if 127.0.0.1 does not work. Also you only need to whitelist (internally) from one machine to the other if you are using SOAP.

Again… assuming you are trying to use a web host to connect (not on the same machine), then you need to whitelist that on your router to handle the (external) connection.

Default Example:

[FONT=‘Courier New’]SOAP.Enabled = 1[/FONT]

[FONT=‘Courier New’]#
# SOAP.IP
# Description: Bind SOAP service to IP/hostname.
# Default: “127.0.0.1” - (Bind to localhost)[/FONT]

[FONT=‘Courier New’]SOAP.IP = “127.0.0.1”[/FONT]

[FONT=‘Courier New’]#
# SOAP.Port
# Description: TCP port to reach the SOAP service.
# Default: 7878[/FONT]

[FONT=‘Courier New’]SOAP.Port = 7878[/FONT]

It’s not a repack, and for other help I understand I’m just trying to show that for some reason telnetting is not working on SOAP.

Well I tried using the same machine AND a webhost to use soap and I can’t connect.

I have tried 0.0.0.0 and 127.0.0.1 and nothing has worked. I have NOT tried 192.168.1.XXX to connect and I’ll try that next.

I have also enabled the ports so I don't know possibly what else I can do to enable both internally or externally to connect to SOAP