[SOLVED]6.x WorldServer.exe crashes after updating to 6.2.4 support

After updating my core and compiling, when I start worldserver it crashes.

Machine info:

Windows 10 Pro 646bit i5-2500 12.0 GB Ram

Windows Requirements meet:

Boost 1.59, MySQL 5.6.29, OpenSSL v1.0.2g, ZeroMQ-4.0.4~miru1.0-x64, CMAKE-3.5.1 and Visual Studio 2013 Update 5

This was a completely clean install. After I had the crash the first time.

I completely deleted my core dir, build dir, and I also delete the databases to avoid any corruption issues. And pulled the latest commit for Trinity 6.x and compiled with no errors.

Commit version of Trinity 6.x is: b612eccbe7bac075a5321c7909690d4622796bc9

Database used: TDB_full_6.03_2015_11_08

Server.log PasteBin: http://pastebin.com/C83upEdJ

DBErrors.log Pastebin: http://pastebin.com/gAnYmdUQ

WorldServer Crash log PasteBin: http://pastebin.com/FKBxvs2t

If someone has a suggestions?



i think its about your database

Could not connect to MySQL database at Unknown database ‘auth6x’
Could not connect to MySQL database at Unknown database ‘characters6x’
Could not connect to MySQL database at Unknown database ‘world6x’
Could not connect to MySQL database at Unknown database ‘hotfixes6x’

if your server dosent connect to mysql databases it will close or crash

set your database names in wordserver.conf then try

thats the what i get from this :stuck_out_tongue:

sorry for bad english

No it is not about my database. Those errors happen when you start the worldserver the first time. The worldserver created the four databases needed and updated them. According to the crash log, it looks like something to do with Boost but I am not sure… But thanks Hadifaren for the suggestion.


Try after https://github.com/TrinityCore/TrinityCore/commit/9431b94bff939457cb915da3728cda6067674558

It has nothing to do with the DB.

If your crashlog is to be trusted, the value of HonorPointsAfterDuel in worldserver.conf seems to be invalid. After updating you should see the error being printed to the console.

@Nay What confuses me is his server log ends when it loads vmaps (maybe corrupt data directory or maybe that’s where the setting is wrong? )

this tells me to start looking for errors @ 1. configs or 2. the data for core
Crashlogs arnt always direct when it comes to the error sometimes an other error cause makes something else go wrong in the system

@Todd Did you try extracting all the data again if so try disabling vmaps and mmaps and launch worldserver and see if it crashes again.
if it doesn't you have a corrupt vmap or mmap directory try extracting those.
If the crash persists I would suggest grabbing the new config.dists and config from scratch something isnt right with your settings.

Thank you Nay!! Your fix worked just as advertised and I did see the HonorPointsAfterDuel is disabled, using Zero. I hope in the future commits someone can get HonorPointsAfterDuel fixed. If someone would please close this thread.

Hi Lorac, I just wanted to address your question as it seems some do not.

I actually have two different dbc, maps, vmaps and mmaps, one is 6.2.3 and 6.2.4. I have also tried disabling vmaps, and mmaps to see if they are corrupted. And the same crash happened. When I looked at the Crash log that is when I saw that the error was not caused by corruption. Also I should point out, before I posted this thread I searched the forums, then waited three days and then re-searched the forum. Then I posted the error in a thread here. I thought someone else may catch the problem before me. Oh also another interesting small fact is I have two machines that are setup with exactly the same software on it (one machine is just not as powerful as the other) I use, one for Development and testing, the other is my games server. So when I get duplicate error on both, I figure something is up… lol

The Devs are great on this project!

Thanks everyone that helped!!


Mhmm, HonorPointsAfterDuel is fine in the conf in the repo (https://github.com/TrinityCore/TrinityCore/blob/6.x/src/server/worldserver/worldserver.conf.dist#L2729). I guess you changed it at some point in time?

“0” is a valid value, “Zero” is not

Damn Nay you caught me!.. I did indeed change it! Seeing this is just a interesting project, I have maxed out a lot of settings. I had changed the value to give honor points after duel, so that must not be able to be changed then? So in fact that value I changed caused the crash? Interesting… Had I not changed it from something other than “0” that crash would not have happened? If so, I will be more careful on the values change in the future. Thanks Nay for the correction.

Obviously that config can have other values but you probably specified an invalid value (perhaps because of quotes? int configs can’t have quotes around numbers afaik)

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —