[SOLVED]auth/worldserver.exe crashing

No idea why my last topic was deleted (moderators could at least send a private message with a reason). Anyway did some more research.

My problem is: Whenever I’m trying to run authserver.exe or worldserver.exe, they’re crushing with no error after a second (looks exactly as in logs attached to post). However, there is a small chance that they won’t crush and they’ll start normally.

Trying to run servers from cmd (as suggested in some forum faq) results in the following error:
Error in config file: cannot open file (authserver.conf)
(same goes for worldserver)

Should I compile TC in Debug? Is it going to give any extra info?

Before you delete this topic again, at least specify the reason, please.




First of all, make sure that authserver.conf & worldserver.conf are in the same directory than authserver.exe & worldserver.exe. Look at the file extension: it should be .conf and not .conf.dist (rename them).

Are dbc, maps, vmaps folders in the same directory than authserver.exe & worldserver.exe ?

Yes, everything should be good. I doubt the server would even go that far with .conf.dist files. Here is how it looks:



[…] (Win32, Release) […]

You built the core for 32 bits so

→ are libeay32.dll & ssleay32.dll from 32bits OpenSSL?

EDIT: for OpenSSL 1.0.2c 32bits should be both 1,231 KB & 289KB. For 64 bits 2,028KB & 371KB

Good Night, I have the same bug, both authserver and worldserver crash and show the error. Before update to works on 6.2.0 the server run ok, no problem, when compile after updates to 6.2.0 server no run, only is crash



Fixed, error in mysql libraries

+semncru: not sure what happened but nobody deleted your topics

anyway, try compiling in Debug mode and see what the crashlog says.

same crash too /emoticons/default_mellow.png


windows2008 x64 16G

TrinityCore rev. 678a08c8c5e2 2015-07-04 02:43:43 +0100 (6.x branch) (Win64, Release) (bnetserver)
to stop.

Using configuration file bnetserver.conf.
Using SSL version: OpenSSL 1.0.2c 12 Jun 2015 (library: OpenSSL 1.0.2c 12 Jun 2015)
Using Boost version: 1.57.0
Automatic database updates are disabled for all databases!
Opening DatabasePool ‘auth’. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.6.25
MySQL server ver: 5.6.25-log
Connected to MySQL database at
MySQL client library: 5.6.25
MySQL server ver: 5.6.25-log
Connected to MySQL database at
DatabasePool ‘auth’ opened successfully. 2 total connections running.
Started auth database connection pool.



in the cmake when you give to configure, copy it all the info that sheds, in my case, the problem was that the cmake was using the mysql libraries wrong, and there I realized, I resolved that and the application did not return to give problems or crash

​thx, fixed

[SIZE=13px]problem [/SIZE] in FindMySQL.cmake

Yes, they are. Again, the server wouldn’t have probably initialized with wrong .dlls.

MYSQL_EXECUTABLE and MYSQL_INCLUDE_DIR was set to 64b version of mysql, changing that fixed my problem, thank you very much!

Why are you all compiling in 32 bits when 64 is available?..


I have the same problem , I leave two screenshots.

http://i61.tinypic.com/1199lc0.jpg auth
http://i58.tinypic.com/21btbtx.jpg world

I read some of cmake has been discussed but not understand how to solve the problem.

I put another screenshot Cmake MySQL.


With CMake I’ve compiled 32 bits.

Last month I made the same process and authserver and WorldServer worked well for me.

And now I do not work , if someone could help me with this problem please .

Thank You.

With CMake I’ve compiled 32 bits.

Why do you guys keep compiling in 32 bits when you can do it in 64 bits?

Your libmysql.lib is 64 bits because it’s in C:/Program Files/MySQL. If you insist on 32 bits you need to use a 32 bits MySQL install. There’s a zip on the wiki.

​Thanks for answering! I did not know it was compiling to 64 bits.

I’m downloading the .zip 32-bit, https://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-5.6.25-win32.zip I hope that is correct.

Thank You!

Hi i’m Trying to Run a Trinity Core (master) for Windows 10 x64 bit (install everything x64 and MySQL 5.64), i set up everything as the Trinity Core Tutorial asked me to do,

(this is the link to tutorial https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130077/Installation+Guide) .

I’m almost done But there is a problem ,when i’m trying to run the Worldserver.exe file after 10 sec i get this error :


  • also the bnetserver.exe works just fine.

  • i extracted all the related folder (dbc & maps & vmaps ) from the blizzard PTR (public test realm) Client, Could this be the problem?!

i tried to do the hole process: “Pull” the trinity Core with “GitExt clone” and Remake the “build” folder too ,also i Compiled the Server with Both “Release” and “RelWithDebInfo” method But none of them works and still got the same Error Can someone please help me out.

Trinitycore doesn’t support PTR, you need live client.

Hi im runing a trinity core (Master) for legion expantion, i set up evrything as the TrinityCore Tutalial asked me to do.

thi is the link to tutarialhttps://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130077/Installation+Guide

Oh Thank You so much For Replying, But the problem was not PTR, i miss some files in my “C;\build\bin\RelWithDebInfo” Folder. now it works just fine :wink:

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —