[Solved] Core bekommt beim Compilen Rev 0

Hi @ all,

Habe momentan das Problem das die Core beim Compilen die Rev: 0 zugeteilt bekommt und man somit nicht weis an welcher revision man momentan hängt.

die einzig brauchbare aussage von beim Compilen ist

– WARNING - Missing or outdated git - did you forget to install a recent version?

4> – WARNING - Observe that for revision ID/hash to work you need at least version 1.7

4> – WARNING - Continuing anyway, but setting the revision-ID and hash to Rev:0 Hash: Archive

Git ist allerdings in der aktuellen version vond er Git Homepage installiert

hat da villeicht jemand ne Idee wie man den Fehler beheben kann?

Mfg. Leso

Windows, MacOS oder Linux?

Bei Windows installier GitExtensions, da ist alles drin was du bezüglich git brauchst. Dann noch:

During installation of GitExtension (Installation Option 2+3) the fallowing folder will be added to path variable:

C:\Program Files (x86)\Git\cmd

But in this folder you will only find batchfiles, no executeables.

As mentioned above, I try to insert the folder where the git executeables are located:

“C:\Program Files (x86)\Git\bin” (At Windows 32 Bit “C:\Program Files\Git\bin”).

So I add “C:\Program Files (x86)\Git\bin” to path variable (without “”) , Restart PC and cmake was able to get trinity reviosion number /emoticons/default_smile.png

Please clear your cmake cache or delete the whole build directory!

Windows Server 2008 ^^

aber thx für die schnelle hilfe , werd es gleich mal probieren.

Edit , habs probiert aber funktioniert leider nicht !

Mit wird immernoch Core rev 0 angezeigt , wobei ich den fehler nichtmer im log finden konnte .

Nutze Visual Studio 2010 falls das was zur sache tut ^^

Debian hat das selbe Problem, weil Lenny eine ältere Version installiert ( 1.5 ).

Um dort diese Meldung zu beheben, muss man die Lenny Backspot Repo in die Source List einbringen und von dort GIT installieren. /emoticons/default_smile.png

Nur mal so angemerkt für zukünftige fragen. /emoticons/default_wink.png

Gruß WU

über Debian »squeeze« bekommt man sie auch

einfach Source List editieren

etc->apt->sources.list

deb http://ftp.de.debian.org/debian squeeze main
apt-get update && apt-get install git-all

Hat noch jemand ne Idee für Win?

als bei mir funktioniert das bei Linux und bei Windows ohne Probleme

überprüfe mal deine Git Version

Start->Alle Programme ->Git ->Git Bash

git version

wen deine Version nicht 1.7x.x ist ist sie zu alt.

Hab ich grad gemacht und laut log ist es die aktuelle Version 1.7.3.1.

Hast du GIT vollständig installiert oder benutzerdefiniert?

Hast du CMake erneut ausgeführt?

Gruß WU

Ja soweit schon .

Was verstehst du unter Git benutzerdefiniert?

habe halt ein TrinityCore verzeichniss clone aufm desktop erstellt.

Ich meine damit die GIT installation.

Ob du das komplette Paket installiert hast oder evtl nur bestimmte Module!?

Ich habe GIT noch nicht unter WIN installiert, werde mal ne VM mit Win2008 erstellen und es dort ausprobieren.

Gruß WU

Ach so .

Hab es komplett installiert ^^

http://www.trinitycore.org/f/index.php?/topic/345-howto-properly-install-git-on-windows/

Braucht nur eine richtige Installation.

Ok läuft thx ^^