[SOLVED]Create Database with different name


I have a quick question.

Since after running “worldserver.exe” database will be created itself, I want to ask how can I make the worldserver to create "World3.3.5"instead of “World”? (and same for auth, characters)

tc is getting those database names from worldserver.conf, change the world to world3.3.5

[FONT=‘Courier New’]worldserver.conf.dist:LoginDatabaseInfo = “;3306;trinity;trinity;auth”
worldserver.conf.dist:WorldDatabaseInfo = “;3306;trinity;trinity;world”
worldserver.conf.dist:CharacterDatabaseInfo = “;3306;trinity;trinity;characters”[/FONT]

example (ignore socks)

[FONT=‘Courier New’]worldserver.conf:LoginDatabaseInfo = “.;/var/run/mysqld/mysqld.sock;wow;xxxx;tc_335_auth”
worldserver.conf:WorldDatabaseInfo = “.;/var/run/mysqld/mysqld.sock;wow;xxxx;tc_335_world”
worldserver.conf:CharacterDatabaseInfo = “.;/var/run/mysqld/mysqld.sock;wow;xxxx;tc_335_characters”[/FONT]

Thanks, you can move it to “Solved Issues” section now.

Glad that worked,

I guess for posterity, the the custom database names (such as "tc_335_world") still need grant statements associated with them "GRANT ALL PRIVILEGES ON tc_335_world.* TO 'wow' WITH GRANT OPTION;", but after that everything should be smooth with the modern build system out of the box.


— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —