[SOLVED]Fresh install worldserver error

On a fresh compilation of TrinityCore, I’m getting this error: https://gist.github.com/Aidoboy/21ab0a7a00eca6096dcafad395cfeefc

I’m sure that the conf file has the right mysql details, that the user has the CREATE privilege, and I am on the most recent Trinity3 commit. Does anyone know what could be wrong?

Create the auth, characters and world db manually.

Import https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/base/auth_database.sql to the auth DB.

Import https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/base/characters_database.sql to the characters DB.

Import https://github.com/TrinityCore/TrinityCore/releases/tag/TDB335.61 to the world DB.

And then start worldserver normally. It should automatically apply the SQL updates it needs from now on.

P.S Trinity3?

The same thing happened to me over and over. Are you pulling your libmysql.dll from your MySQL/lib folder?

Woohoo, that worked! I didn’t realize I needed to make them manually.

It isn’t supposed for you to create them manually but there’s a bug somewhere that doesn’t let mysql create the databases or import big-ish files.

Manually importing those files is just a workaround until we find the cause of the problem.

You have imported

https://github.com/TrinityCore/TrinityCore/blob/6.x/sql/create/create_mysql.sql

or

https://github.com/TrinityCore/TrinityCore/blob/3.3.5/sql/create/create_mysql.sql ?

Ah, ok.

I didn’t import either, but it seems to be working now.

Also on a unrelated not, should the death knight initiates in the starting area be attacking the scarlet crusaders? They just seem to walk around nonchalantly.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —