[SOLVED]I can't connect to my own server...

I am running 6.x

I edited my wordconfig, and my bnetserver.conf and put my correct mysql information in there.

I went into the realmlist.wtf in the wow/wtf directory, and pointed the portal to my localhost.

When I try to login it it says “you have been disconnected.” I feel like it’s not even pointing to my server??

It doesn’t even attempt to login. I did create the account on the server (through worldserver.exe) . Is there a reason this is happening?

1/2 02:43:10.378 Failed to resolve localhost.logon.battle.net
1/2 02:43:10.392 LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED
1/2 02:43:10.392 Login program=WoW platform=Wn64 locale=enUS
1/2 02:43:10.392 Component WoW.Wn64.20779
1/2 02:43:10.392 Component WoW.base.20726
1/2 02:43:10.392 Battle.net is Component Bnet.Wn64.37165
1/2 02:43:10.392 Client Disconnect due to reason:8

I am running bnetserver.exe and it seems that it’s not even picking up a connection from WOW. And yes my WOW is fully upgraded. (I own WOW)

EDIT: Nevermind. I didn’t realize I had to run the connection_patcher from the given tools. I got it. Thank you!

Try to use authserver.exe instead of bnetserver.exe and delete the cache of your Client, because it seems like it tries to connect to ‘localhost.logon.battle.net’.

There is no authserver on wow 6.

Oh i didn’t know that.

However the client tries to connect to logon.battle.net

He fixed the issue, he was running non-patched binary.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —