[SOLVED]Missing "Addons" Button on character creation

I am using 3.3.5a trinity emu for my private server offline. I tried googling and searching this forum. I know how to extract the relevant version and add it into the Addons folder in the interface folder. However, the addons button that usually is seen on character creation is missing so I can not load any addons. Can anybody help with this, will be greatly appreciated.
Thanks

The button is show only if you have addons directories inside interface\addons directory.

Does that mean I add a folder called “addons” at interface/addons? I did that but the button did not show up

No, every addon must have their own directory inside interface/addons, instead zip/rar files, ie Maps, BT4, etc

Yes I have it exactly like that, e.g. Interface/addons/QuestHelper

And my addon, quest helper, is already extracted and in folder form

works for me ™ be sure your [COLOR=rgb(39,42,52)]QuestHelper don’t have a directory called [COLOR=rgb(39,42,52)]QuestHelper inside.

Oh wow that was the problem, I feel silly. Thank you so much for your help. This is what happens when you are only used to programs automatically doing it for you in modern WOW, you forget how to do it the old fashioned way.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —