[SOLVED]Problems setting up server

Hi,

System: Mac OS El Capitan 10.11.2

I have followed this guide: https://community.trinitycore.org/topic/10515-howto-compile-trinitycore-on-mac-os-x-using-homebrew/ to build Trinity. My build succeeded after a tweak of myself (changing mysql path).
First issue occurred: What did I actually just build? Some kind of Trinity base that is necessary no matter if I want to run 3.3.5 or 6.x? If it does matter, how could I chose JUST to install 3.3.5, I couldn’t find that in the guide.

Anyway, my build succeeded and I went straight into the next step (server setup): https://trinitycore.atlassian.net/wiki/display/tc/Server+Setup
Now a few new problems appear for me:

[ul][li]I should extract Vmps, MMaps using Trinity extractors. At first DTOOLS=1 was not set, because it was not mentioned in the guide above. I tried to re-run the ‘CMake-Config-Thing’ but after adding -DTOOLS=1 at the end of the parameter list and paste it into the console it executes it directly… apparently without using the last parameter. If I add -DTOOLS=1 somewhere inside, it also executes everything directly but leaving out the last parameter which is then of course “-DWITH_WARNINGS=1”. Why does the console executes it directly?[/li]
[li]How do I install/build the extractors and where to find them afterwards and how to use 'em?[/li]
[li]In the guide it says “unknown makro: ‘localtabgroup’”, I guess the wiki page is somehow corrupt? Well, I was going through this tutorial because I have no idea and now something essentiell is missing -.-[/li]
[/ul]
For the moment my build succeeded, but I don’t know if it contains everything necessary and whether its prepared for 3.3.5, 6.x or both of them.

Which are the next steps from now on to get me past WoW Login Screen?

I hope someone can help me out! I’d suppose a lot of people encountered similar problems and might have fixed them already.

Thanks in advance,
chakuze

The problem is solved. This can be closed now.

Can you explain what you did so someone else with the same issue can come here to know more about it?

Sure!

[ul][li]I still don’t know why it executes it directly, if you add -DTOOLS=1 in the end, but it doesn’t matter. First your run the complete cmake stuff written in the tutorial and after your run again cmake with just -DTOOLS=1 as parameter[/li]
[li]Extractors are located in the /bin/ folder of your builded realm[/li]
[li]You use them by doing this:[/li]cd /Users///
mkdir data
cd data

[li]mkdir buildings vmaps mmaps[/li]
-i

-l -d /Data

buildings vmaps

[/ul]
If anything is unclear, post here :slight_smile:

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —