[SOLVED][SOLVED] Debian TrinityCore 3.3.5a - Can't start worldserver

Hello everyone, I’m having a bit of trouble getting my server working.

I’m following this guide https://trinitycore.atlassian.net/wiki/display/tc/Databases+Installation and everything up to “Start worldserver and press enter when it asks if you want to create databases.” worked fine. But I just can’t get worldserver to start.

I’ve copied the TBD_full sql file to /home/wow/server/bin, which I assume it where it should be. I then try to start worldserver using “sh worldserver” and it then gives me the following error.

sh world server

root@debianwow:/home/wow/server/bin# sh worldserver
worldserver: 1: worldserver: +iA,@: not found
worldserver: 1: worldserver: !DHD2E8D@8t0
@m
: not found
worldserver: 1: worldserver: AAQA: not found
worldserver: 1: worldserver: ELF: not found
worldserver: 3: worldserver: Syntax error: “)” unexpected
root@debianwow:/home/wow/server/bin#

I’ve changed the worldserver.conf to match my MySQL database settings.
I’m using Debian 8.4.0 x64

If you need any other information let me know.

worldserver is a binary…

I found the solution, apparently I have to start it by using ./worldserver. I’ve tried just worldserver before but that didn’t work.

Sorry I’m new to Linux.

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —