[SOLVED][SOLVED] Discrepancies between Install Guide and Code Entry

I wanted to ask if there has been any updates in the code that have not been reflected in the install guide? When I try to create a GM account in the WorldServer.exe, what the directions state on the Install/Setup guide are not corresponding to what the syntax of the WorldServer are returning to me, thus is making GM account creation impossible. See screen capture. Please advise. Thanks!


Apologies for the frustration exhibited in the last command…

on master branch you need to use the bnetaccount create command. See bottom of https://trinitycore.atlassian.net/wiki/display/tc/Server+Setup

Hmm, and I guess the issue was that you tried .account set gmlevel 3-1
but it failed?
You need to use a space between 3 and -1

@Rochet2- I did! If you see on my screen shot I submitted, about 1/3 of the way down, I created the account successfully. What happens next is the gm account creation. Thats where I’m stumped.

See my edits :slight_smile:
I was unable to read the text on the console at first.

Such minor spaces drive me nuts. :slight_smile: I did try it but it is still giving me “account does not exist” returns. Even when I make a brand new account and log in with it.

What was the account name you used? Was it 2#1?

Not my BNet account, Test@Test with Realm Trinity. But my Player name Archaeus.

I logged into the server and created a new player. Then I quit the WoW app and tried to get the GM applied to the character I just created, in this case Archaeus. Is that the proper methodology?

GM rank is applied to the whole account. You dont use the email or anything like that in the commands, you use the 2#1 in them as the account name.

so .account set gmlevel 2#1 3 -1

I’ll give it a shot and report back with screen cap if it fails. Stand by please.

All worldserver commands must be done with the client closed, right?

hmm, no
But you want to relog after doing changes to an account for example.

Understood. I tried the command and it took! But relogging now to see if they applied it successfully.

Its working! All as intended. Thanks @Rochet2!!!

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —