[SOLVED]Stuck on connected 6.x server

I just compiled the 6.x server and bnetserver and worldserver is running, the address in realmlist is set to 127.0.0.1 and my config is set to "SET portal “127.0.0.1"”, everything is setup right, but when I launch the game and login I get stuck on “connected” my game is 6.2.3 20886 and I have the latest version of the 6.x since I compiled it an hour ago

I didn’t mean to post two of them the first time it had an error but still posted it.

“Latest” don’t supports 6.2.3 and it’s still broken.

Oh I see, what shall I do then in order to connect to my server?

Wait.

Okay will do, so if I wanted to play Warlords of Draenor I’m best to download a repack is that correct?

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —

This is the last commit working with 6.2.3.20886 https://github.com/TrinityCore/TrinityCore/commit/363731aac827f3eab051064ba466cef49f6cc111

Anything beyond that is a working-in-progress on 6.2.4 and is not usable