[SOLVED] Trinity Core auf 32 bit Maschine in x64 compilieren

Hallo Zusammen,

ich versuche gerade den trinitycore auf einer Windows 32bit Kiste für x64 zu kompilieren.

Das scheint nicht zu funktionieren.

Ich habe auf der 32bit Kiste alles lt. http://www.trinitycore.org/w/How-to:Win installiert.

VS 2010 als Vollversion, die restlichen Komponenten als 32bit-Versionen.

Muss ich um x64 kompilieren zu können die jeweiligen 64bit-Varianten der jeweilig benötigten

Software installieren (SQL-Server, Open-ssl)??

Sorry für die noob-Fragen, aber ich komme nicht weiter…

Vielen Dank für sämtliche Hilfe vorab.

Viele Grüße

Ashikaga

du kannst unter 32 bit nur für 32 bit kompilieren, gleiches gillt für 64 bit

es reicht auch nicht aus die 64bit programme zu installieren, denn du brauchst nen 64 bit OS, also win7 64bit als beispiel, erst da laufen die 64 bit versionen

das geht nicht auf Windows 32 kannst du nur als 32bit zu kompilieren

um auf 64 bit zu kompilieren benötigst du Windows 64 bit

Ok, dachte ich mir, wollte aber nochmals nachfragen.

32bit funktioniert problemlos zu kompilieren. Der Server funktioniert dann auch (maps etc. vorhanden).

Das Kompilat kann ich dann aber nicht auf einer 64bit Maschine laufen lassen, oder?

Super vielen Dank für Eure schnellen Antworten!!

Doch du kannst dein 32bit Programm auch auf 64bit Maschinen laufen lassen den die meisten 64bit Maschinen können auch 32 bit verarbeiten.

Gut, das habe ich probiert, bekomme den authserver auch gestartet, den worldserver leider nicht.

Ich habe in der worldserver.conf alle Einträge zur Logschreibung aktiviert, bekomme aber

kein Logfile, nirgends.

Ebenfalls habe ich in den beiden conf-Dateien den Zugriff auf die Datenbanken des SQL-Server

bzgl. des Logins angepasst.

Auth.log:

2011-01-26 11:25:10 TrinityCore Rev: 0 Debug Hash: Archive (Win32, little-endian) (realm-daemon)

2011-01-26 11:25:10 to stop.

2011-01-26 11:25:10 Using configuration file authserver.conf.

2011-01-26 11:25:10 Added realm “Trinity”.

2011-01-26 11:25:10 TrinityRealm process priority class set to HIGH

2011-01-26 11:25:10

Aber leider startet worldserver.exe nicht, geht direkt zu, und schreibt kein Logfile?

Was kann ich probieren?

überprüfe erst mal deine confing da liegt wahrscheinlich der das Problem

Ich habe gerade nochmal alles kopiert und in den Config’s nur den Zugriff

auf die Datenbanken geändert…

siehe da:

LÄUFT!

Vielen Dank!