[SOLVED]Unable to connect to 6x

Hi all,

wondering if someone might be able to point me in the right direction.

I wanted to try out the 6x branch of the server so here’s what i’ve done so far:

i pulled everything yesterday and compiled (TrinityCore rev. 7f8cd123c43b 2016-03-28 23:10:44 +0100 (6.x branch) (Unix, Release)).

Updated my client to via WoW Launcher / Battle.Net

ran the extractors (dbc / maps / vmaps / mmaps),

updated my configs with the new versions,

loaded the db (TDB_full_6.03_2015_11_08) from scratch,

edited the realmist table and changed both ‘address’ and ‘localAddress’ to

and ran bnetserver and worldserver. They updated and are running.

Created an account

I updated my client config.wtf to add

SET portal “”
SET patchlist “”

ran the connection patcher on wow.exe (on linux), copied it back to my wow install

bnetserver and worldserver are running on a linux server ( that is also successfully running 3.3.5a (it’s stopped at present).

Ran Wow_Patched.exe (same LAN as the server) and tried to log in and got the error

‘You have been disconnected. (BLZ51901021)’

BattleNet.log has the following:

3/30 11:43:28.790 [IBN_Login] Starting up | hasFrontInterface=false | hasBackInterface=false
3/30 11:43:55.244 [GlueLogin] Starting login | launcherPortal=nullopt | loginPortal=
3/30 11:43:55.244 [GlueLogin] Resetting
3/30 11:43:55.244 [IBN_Login] Initializing
3/30 11:43:55.244 [IBN_Login] Attempting logon | host= | port=1119
3/30 11:43:55.244 [GlueLogin] Waiting for server response.
3/30 11:43:55.441 [IBN_Login] Front disconnected | connectionId=1 | result=( | code=ERROR_NETWORK_MODULE_FAILED_TO_DOWNLOAD_CERT_BUNDLE (1021) | localizedMessage= | debugMessage=)
3/30 11:43:55.441 [GlueLogin] Fatal error while logging in | result=( | code=ERROR_NETWORK_MODULE_FAILED_TO_DOWNLOAD_CERT_BUNDLE (1021) | localizedMessage= | debugMessage=)

Thought maybe that error had to do with the two new (to me) files in the bin folder, bnetserver.cert.pem and bnetserver.key.pem

Wasn’t sure what to do with them, so i thought maybe they followed the same pattern as the bnetserver.conf.dist, so i copied (not renamed) both of them to ‘bnetserver.cert’ and ‘bnetserver.key’.

all 4 files are in the same folder as bnetserver and worldserver.

I restarted bnetserver and worldserver and tried again, with the same results

firewall on server is currently inactive (ufw)

now i’m stuck. Any suggestions?

I’m having the same problem…

Yep, me too. No sure why.

Configure the new lines in the bnet config file, they are bind to in local and external… in external put your external ip and local put 192.168.x.x

It works for me on Windows 10

FFS when will you people learn that copying the patched exe from another machine alone IS NOT ENOUGH? You need another file in wow installation folder - tc_bundle.txt

Mmmm … My problem is that the connection patcher does not work on any other PC. Only the server where it was compiled.

Perhaps it is missing something or maybe has not been compiled well. I tried to use it on multiple PCs and does not work. I supposed that caused the error.

When I try to use the patch, he says "The program is very big to fit in memory"

Do you have openssl on that machine?
or Microsoft redistributables?

If not this may be your issue

I tried that, but it does not work. It’s weird because in version 6.2.3 worked perfectly on all PCs but this version no.

are you building core in dynamic or static?
If you are building in dynamic i believe you need to place a copy of common.dll in the same folder as the patcher and wow.exes for it to work Im not sure though i havent explored the linking to see for sure if they split the common.dll on patcher besides the dynamic linking and the overall bnet restructure thats the only change i can think that would impact you like this

If you are building dynamic try changing over to static in the dropdown and rebuild tools and try that patcher on the other machines
If it patches that is your problem you failed to include one of the required dlls from build directory

Well, I tried to add the .DLL but no effect. Maybe it is because what you say. But I do not know how to toggle between static and dynamic.

Thanks for the help anyway. I will continue investigating.

If you look at cmake you will see an option “with dynamic linking” make sure it is unchecked to build it as the old core where its 2 core bins and your configs and tool bins
by placing the check in place it splits the systems into separate dlls which is nice to have when you are constantly changing things and debugging Delete everything in your build directory and rerun cmake if you have the check in the dynamic linking

try removing the check mark and rebuilding the tools that way and see if its any better :wink: i really think this is your issue your having with patching on systems you didnt build the bins on

I think I oversimplified “copying the patched exe”, i copied the entire installation from windows → linux, ran the patcher, then copied the entire install from linux → windows. I should have specified that.

I’ll try again and make sure all files are in place - and see if some of the above suggestions work and post back.


Yep, I was missing the tc_bundle.txt. I cleaned up the wow folder a bit and must have selected that file when I did.

I’m now able to connect, but getting an ‘incompatible’ realm.

Looking into that now!

Thanks Shauren!

Incompatible? realmlist.gamebuild controls that.

Yep, I changed that to the 21355[COLOR=rgb(39,42,52)] per the client supported post, restarted the server and still getting the incompatible message.

Changed the realm name to 6X so I know it’s connecting to the right db - bnetserver shows 6x and so des the realm list after login.

try SET portal “” at config.wtf and repatch.

Changing the gamebuild and restarting server didn’t work, still incompatible.

Tried that with and

still getting incompatible realm.



so apparently my dyslexia and inability to check each number kicked in…

i put in ‘21335’ instead of ‘21355’.

Connecting now…

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —