[SOLVED]Updating Commit - Question

I have followed the instructions exactly as to the updating process of commits for my MASTER server, but I have a question that I cant seem to locate the answer to already on the forums. My current commit is running e0fb444. I open GItExt and look for the newer commit, however it is nowhere to be found. Refreshing GitExt brings up…

http://i.imgur.com/yCnc8QE.png

… which is currently my current commit. Yet on the website, I am seeing several commits that have been done after my commit (e0fb444). See below.

http://i.imgur.com/bFLe3Tw.png

I’m seeing 79b9848 as the most up to date commit. Am I wrong in this presumption? How do I get this commit to show up in my GitExt? Any guidance would be appreciated.

Thanks!

instead of refresh (whatever that does , maybe it doesnt do any git commands that change history etc, just refreshes the GUI view), fetch or pull. Fetch gets latest history so you can see the commits (but dont actually have them in your current source) and pull would do fetch and merge (and merging means you would get the stuff(the commits) to your current local repo)

I myself dont use any GUI so no idea how git extensions works for example. Im sure many have used or know how the CLI works however so maybe use that instead and then use GUI?
Easier to sort these things out in the CLI than in some random GUI - there is just one CLI.

Thank you. Will give it a shot.

That worked. After recompiling, Im working on fixing a WorldServer crash issue before I can actually get in game.

http://i.imgur.com/CS0oSVH.png

The refresh button in Git Extension only updates the GUI.

You are missing the VMap files. You can either extract them (recommended) or disable vmaps in worldserver.conf

Already extracted and copied from my previous commit folder. For some weird reason or another its still showing the same error. Here’s 2 pics of 2 folders. My dir of the WorldServer and the contents of the vmaps folder.

http://i.imgur.com/jKQeta2.png

http://i.imgur.com/FAx3mUg.png

@Nay Thanks for your input, can you please advise me further? I’ll post screen caps of whatever you need to see. Thanks!

  • J H

It probably doesn’t matter, but the BNet server works fine. its only the worldserver.exe that’s giving me fits right now. I’ve redone the entire procedure 3 times and every time it gives me the same result at the same point in the setup. There’s got to be something I’m missing. I ran my previous commit on this rig the exact same way. I’ve double checked the worldserver config file for any discrepancies but since I connect to the localhost, all entries have been set to defaults and I haven’t touched anything. Thoughts?

http://i.imgur.com/BSRBU9q.png

Is there any place I need to double/triple check the path for the vmaps? If its default - does that mean just running off the C: dir?

You can set the DataDir config to an absolute path instead to be sure.

https://github.com/TrinityCore/TrinityCore/blob/master/src/server/worldserver/worldserver.conf.dist#L76

For example, I have all the client files in DataDir = “D:/wow/335/data”, outside of the build directory.

Also - what is the downside to disabling vmaps in the config?

Heres what I have currently in my worldserver.conf file. I don’t need to edit anything or change anything to make it “Proper” right?

http://i.imgur.com/VAY6iYE.png

http://i.imgur.com/AIXSND7.png

I will work on giving that a shot. I find it more organized and meaningful to have frequently access files in an easy-to-remember location as well.

No change in behavior. No matter where I move the files to, it cant find the vmaps files even though the vmaps are clearly present in the C:/Trinity/Data folder.
(Which is what I entered in the config file.)http://i.imgur.com/wZFnWoD.png

http://i.imgur.com/sVuYxAb.png

looks correct to me. However, have you tried using forward slashes (/) instead of backslashes () ?

very likely he needs to re-extract vmaps and mmaps.

@Aokromes - Thats my last resort. You’re probably right and I will try that after reversing the slashes as @Rochet2 suggested. Its always a shot. However, if one commit can recognize everything in the vmaps and mmaps, why wouldn’t a second? Just a thought.

(For the record, I did not delete my previous commit. I wanted to make sure I had everything on hand as a fallback / backout plan. I threw the vmaps and mmaps and everything back into my previous commit and it worked fine.)

Changing the direction of the slashes yielded no success. Same results. Will re-extract and test.

Slightly troubling that it says the file doesnt exist and re extracting would be the solution.

If it is, then the error messages probably need a bit of a tweak or something.

I agree. @Rochet2 What also baffles me is that it will work if moved to a previous commit but not work in a newer one. I just logged off retail and am now going to try this all again. I’ll update momentarily.

-J

Frig…Extracted fresh vmaps and nothing different.

http://i.imgur.com/6yPBrNW.png

So…whats the difference between disabling vmaps and having them enabled?