[SOLVED]worldserver: command not found

I followed the instructions ( i think )

compile went OK (i think, didn’t see any errors)

downloaded the database and copied the file as required

got to the point where the instructions say to run worldserver

I cd’d to the folder /server/bin and typed “worldserver” and got the message

worldserver: command not found

so i typed dir and it appears to be there

here is a copy of the terminal showing commands and results

wowuser@Minecraft-Server:~/server/bin$ worldserver
worldserver: command not found
wowuser@Minecraft-Server:~/server/bin$ dir
authserver mmaps_generator vmap4assembler worldserver
mapextractor TDB_full_world_335.61_2016_04_11.sql vmap4extractor

anyone have any idea why it wont run

[FONT=Courier New]./worldserver[/FONT]

Generally learning how to use your OS is recommended before attempting to run a server.

Under linux, you have to provide at least the local path (the “./”) as part of the command because the local path is not in the PATH variable (where the shell searches for executables). This is because it’s considered a security risk according to the answer to this question:
http://askubuntu.com/questions/320632/why-do-i-need-to-type-before-executing-a-program-in-the-current-directory

I can shine some light on the security aspect of the PATH variable, in short:

The PATH variable is where your shell searches for commands to run and generally speaking the default directories are only writable by system admins. This means that the chances of you running a seemingly innocent command ends up wrecking your system.

However, if you choose to accept the above risk, you can edit ~/.profile with the following line:

PATH=/dir/to/be/included:$PATH

This will add /dir/to/be/included in your PATH variable.

  • Shameless plug: But, you could also install these:

— Canned message start —
It appears the issue in the original post was solved, so this thread shall be closed.
Should you encounter any other difficulties, please open a new thread.
— Canned message end —