Starting up auth and world servers under debian

Is there a particular way to start world and auth servers for 3.3.5a on Linux so that you can execute commands like adduser in the command line or something?

On winblows 7 there was a dos box that started up when starting up the servers, and I could add users and use other commands in the worldserver’s dos box.

TrinityCore rev. a10870571558 2018-09-03 22:06:51 +0200 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (worldserver-daemon)

I just open a terminal window, cd to the server directory, and enter “authserver & worldserver”.

I tried that, but it comes back with:

[email protected]:~/server/bin$ authserver
bash: authserver: command not found

or you cloned master branch or you forgot make install. PS. start worldserver before authserver.

Same result. I can get them running when I use the Files window and navigate to the /trinity/server/bin folder and double click on them.

I’ll try re-pulling from repo and go through the process once again.

*Going to play with the CMAKE switches. I used the default according to the wiki, but I also noticed -DSERVERS=1 not set.

Well, I’m starting to think it may be something to do with debian. I rebooted and logged into the user account Trinity to redo all this with.

I then started by pulling a fresh new pull from the repo using “git clone -b 3.3.5 git://”

And followed the rest of the steps 1 at a time.

I did the cmake configuration and generation, then used ‘make’ and when it was finished hit the return key for the ‘make install’ part.

Tried to run servers and still get the “bash: worldserver: command not found” error.

[email protected]:~/server/bin$ worldserver
bash: worldserver: command not found
[email protected]:~/server/bin$ dir
authserver mmaps_generator vmap4extractor
mapextractor vmap4assembler worldserver
[email protected]:~/server/bin$

The funny thing though, is I can still run the servers. I see them listed as running on the System Monitor, and can log in with my client straight to my character.

ls -lh better than dir. also, i use debian to run trinitycore since the 1st year.

I’m getting this on CMAKE: “CXX target worldserver cotired without unity build.”

Good or bad?

./worldserver in the directory where the file is located in terminal, is the same as worldserver.exe in a dos box

You are correct! Was just doing some duckduckgo on my problem and it has something to do with my paths, but as you stated ./authserver and ./worldserver in the bin folder worked like a champ.

Thanks for the help every one and the linux commands as well.

Close this please, Aokromes.

Is this important? I’ve always done it the other way round with authserver redirected to /dev/null, but it’s easy enough to change the script.

on 1st install yes,