Supported Client version

Hello, i know that is stupid but which version of wow is supported by the 6.x branch?

Soon 6.2.0(20201).

How soon?Is this wroth it to downgrade the client or just wait for the TC update?

‚ÄčI can just show you that developers already started to work on 6.2.0:

https://github.com/TrinityCore/TrinityCore/commits/6.x

there is no estimation about how much it will take. Other developers are also already busy working on the upcoming new TDB release.