Trinity Core 3.3.5:Brauche ich Windows =>8 zum compilen? | TOOL binaries?

Hallo,

ich habe ein Problem mit dem compilen vom Trinity Core(3.3.5 https://github.com/TrinityCore/TrinityCore/tree/cc00321409707e50da0826b758bcd1242d7fcec7).

Ich habe versucht Visual Studio 2013 Express zu Installieren, leider bekomme ich immer wieder die Meldung das ich eine neuere Version von Windows brauche.

[ATTACH]1246._xfImport[/ATTACH]

Kann man Trinity Core nur mit Visual Studio 2013 Express compilen und ist eine neuere Version als Windows 7 erforderlich?

Um es genau zu nehmen brauche ich nur die TOOL´s. Da der compilungs Prozesses auf dem Server (Linux) funktioniert hat, nur fehlen mir jetzt die MAPS, VMAPS etc.

Gibt es irgendwo Fertige MAPS mit der Version 1.3 oder die TOOL´s schon fertig compilt?

Map file ‘./maps/0004331.map’ is from an incompatible map version (MAPS v1.2), MAPS v1.3 is expected. Please recreate using the mapextractor.
Correct .map files not found in path ‘./maps’ or .vmtree/.vmtile files in ‘./vmaps’. Please place .map/.vmtree/.vmtile files in appropriate directories or correct the DataDir value in the worldserver.conf file.
Mfg.

Windows 7 und VS 2013 ist ok.

Schau mal ob dein Windows das richtige ist (32/64bit) und ob du alle Updates hast inkl. Service Pack 1.

Aber lad dir besser mal das VS Community 2013 runter. Das steht auch in den Requirements:

http://collab.kpsn.org/display/tc/Requirements

(Noch ein Tipp: Lad es dir in Englisch runter. Falls du mal Fehlermeldungen suchen oder posten musst, ist das besser. Die deutschen Texte versteht kein Mensch ^^)

Nachdem ich VS Community installiert habe und einmal gestartet habe bekomme ich einen Fehler in CMake, das ich eine Falsche Version benutze.

[ATTACH]1247._xfImport[/ATTACH]

Also ich selber nutze Visual Studio Express 2013 for Windows Desktop mit einem Windows 7 SP1.

Aber da im TC Wiki die Community Version empfohlen wird, hab ich das mal so weitergegeben :wink: Sollte aber auch gehen.

Offenbar hast du noch eine alte Version VS 2012 (Version 17). CMake hat da so ne komische Versionierung. VS 2013 ist Version 12 und CMake Version 18. :slight_smile:

Also entweder die ältere Version löschen, falls nicht mehr gebraucht. Was du auch noch machen kannst, ist in CMake File->Delete Cache. Und dann das ganze Prozedere mit Configure und Generate nochmal. Vielleicht hilft’s.

Edit:

Vielleicht hilft noch dieser Link: http://emudevs.com/archive/index.php/t-2988.html

Super danke, hat funktioniert.