TrinityCore Extracting

My guess work,

From the snippet, we see that your DataDir is ./ and that $DataDir/mmaps worked fine, but $DataDir/vmaps didn't. From this I feel that the error that reads "VMap file './vmaps/000.vmtree' does not exist" is actually "VMap file './vmaps/000.vmtree' does not exist [B]for the version of the extractor-[/B][B]worldserver combination.[/B]

When making a version of tc (worldserver and tools), the extractor from the tools is made only for use with the world server (and vice versa).

So make sure that the "I start of copy -> paste" is executing the extractors from the same compile you made your worldserver from. If you have some other extractor version laying around, make sure that isn't used .... this is a problem.

I don't run windows, but i would expect to see authserver  mapextractor  mmaps_generator  vmap4assembler  vmap4extractor  worldserver in your bin directory, I do not ... so this suggests to me you are running 'tools' from another version or at least that was not compiled with your worldserver

Compile servers+tools, use the newly compiled tools to extract, populate the datadir ... fire up the database, copy the TDB, run the servers, profit.

Hello guys! The problem is not [SOLVED]. So I figured out that I have not executed all extractors… Thanks for your help!!