Trying to create a second realm

I am currently trying to add another realm to my server.

[ul][li]I have set up 2 new world and characters DB and copied SQL tables over from the first realm.[/li]
[li]I copied the first realm files (/server) and made a new folder called (/server2).[/li]
[li]I changed the worldserver.conf to new ports 8086 and added the new dbs to it.[/li]
[li]I’ve also tried to change the SOAP port from 7878 to 7879 and turning it off.[/li]
[/ul]
When I turn on the worldserver for the second realm, it crashes and tells me it can’t bind to port 7878 since it’s in use from the first realm.

[ol][li]I run auth and worldserver from the first server folder.[/li]
[li]I then try to run worldserver for the second realm and the error persists.[/li]
[/ol]
I am running TC on latest SSL/TC core on Ubuntu 18


I have also tried to cmake into the second realm folder (/server2) and I get greeted with this error:

root@ns3085132:~/TrinityCore/build# make
[ 4%] Built target g3dlib
[ 4%] Built target Detour
[ 5%] Built target Recast
[ 6%] Built target fmt
[ 9%] Built target jemalloc
[ 9%] Built target gsoap
[ 10%] Built target mpq
[ 10%] Built target revision_data.h
[ 14%] Built target common
[ 14%] Building CXX object src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o
fatal error: file ‘/usr/include/linux/limits.h’ has been modified since the
precompiled header
‘/root/TrinityCore/build/src/server/database/cotire/database_CXX_prefix.hxx.pch’
was built
note: please rebuild precompiled header
‘/root/TrinityCore/build/src/server/database/cotire/database_CXX_prefix.hxx.pch’
1 error generated.
src/server/database/CMakeFiles/database.dir/build.make:427: recipe for target ‘src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o’ failed
make[2]: *** [src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o] Error 1
CMakeFiles/Makefile2:1124: recipe for target ‘src/server/database/CMakeFiles/database.dir/all’ failed
make[1]: *** [src/server/database/CMakeFiles/database.dir/all] Error 2
Makefile:129: recipe for target ‘all’ failed
make: *** [all] Error 2
root@ns3085132:~/TrinityCore/build#

I fixed my error myself.

I restarted my VPS, re-downloaded TC and re-started the CMake process.

I was greeted with an error saying that my version of GCC wasn’t the same the CMaker wanted. I just changed the version number in the settings.cmake file and it ran.

No errors after that. Everything installed properly.