Visual Studio Errors!!!

i did the whole database installation tutorial and by the time I build it, errors just pop out. For example

Severity Code Description Project File Line Suppression State
Error LNK1112 module machine type ‘x64’ conflicts with target machine type ‘X86’ authserver C:\Users\Xeleta\Desktop\WoW\build\src\server\authserver\libboost_program_options-vc140-mt-1_60.lib(value_semantic.obj) 1

Severity Code Description Project File Line Suppression State
Error LNK2019 unresolved external symbol “class boost::system::error_category const & __cdecl boost::system::generic_category(void)” (?generic_category@system@boost@@YAABVerror_category@12@XZ) referenced in function “void __cdecl boost::system::`dynamic initializer for ‘errno_ecat’'(void)” (??__Eerrno_ecat@system@boost@@YAXXZ) mapextractor C:\Users\Xeleta\Desktop\WoW\build\src\tools\map_extractor\System.obj 1

there are more errors and here is the release bin

wtf is going on?

[ATTACH]1716._xfImport[/ATTACH]

  1. What are the details on your operating system (Windows version etc.) ?

  2. Which version of Boost and MySQL have you installed (including details about Win32/Win64)?

  3. What are the settings in CMake, can you post or link a screenshot here?

  4. Which version of Visual Studio are you using?

(I could go on about details, but I hope you get an idea of how much info we need to be able to help you.)

LNK1112 module machine type ‘x64’ conflicts with target machine type ‘X86’

I’m not sure if this will help but looking at the error message, it appears that either the target compile or “build” is either mixing up x32 and x64 libraries, the target code is x32 but attempting to be built as x64 or the system it’s being built on doesn’t have x64 ability. I believe when I compiled everything here I used the x32 (Win32) option and kept everything x32.

http://stackoverflow.com/questions/3563756/fatal-error-lnk1112-module-machine-type-x64-conflicts-with-target-machine-typ