Applying update “2018_03_08_04_world.sql” ‘120F9AB’…

Warning: Using a password on the command line interface can be insecure.

Applying update “2018_03_08_05_world.sql” ‘3925C6D’…
Warning: Using a password on the command line interface can be insecure.

Applying update “2018_03_08_06_world.sql” ‘4B8E174’…
Warning: Using a password on the command line interface can be insecure.

Any ideas on that, guys? How can i prevent this message, and what are they implying? Might it be using root ?


the 1st thing, ignore. the 2nd and 3rd thing, you look to use a dirty database, i sugest you to drop world database and download TDB 64 and leave core to import it.


Unknown item (entry=5301) in creature_equip_template.itemEntry1 for entry = 6394 and id=1, forced to 0.
Unknown item (entry=12950) in creature_equip_template.itemEntry1 for entry = 6395 and id=1, forced to 0.
Unknown item (entry=2552) in creature_equip_template.itemEntry3 for entry = 6407 and id=1, forced to 0.

I extracted the lastest Wotlk 3.3.5 TDB, but the worldserver still shows this. Still need help please… this issue remains [UNRESOLVED].


Dead forums or what? 10 days and still no reply…

Im still having these errors… Especially the creature_equip_template… this is delaying my worldserver.exe startup by more than 1 minute… for nothing. I tried implementing a new DB and dropping my old one…

I still have the same problem… [UNRESOLVED]

custom things, you must resolve yourself or importing a clean database.

I understand what you’'re saying. I have dropped the whole Database and imported a clean one. But i still experience the same messages on worldserver.exe

I think it is screwed up on trinitycore. Check out the TDB 3.3.5 My theory is that trinity might have mistakenly used master’s templates? because in the DB the verified build of creature_equip_template is 18,019.

Correct me if im wrong. This is a new Fresh database added from Trinity’s latest TDB 64. So im really confused as to why or how this is happening. If the case was that trinity made a mistake, i believe many people would be posting about it.

I tried even compiling a new core with a totally fresh new Database and i still get the same error… i just don’t get where this is coming from.

Im totally puzzled

you may have bad dbc files.

If that is the case, i need a new wotlk client i presume? Because the DBC files are generated from the wotlk client, correct?


Thank you for the guidance, this must be it, as i have had issues with my wotlk client previously, not being able to transfer it from my external hard disk onto my local PC.

This might just be the issue, i will get back to you and update this thread based on the results.

Kind Regards,


Okay, I tried putting a new DBC, they were gone. However i have custom items in the DB & i have exported all the item_template table to the DBC. I have done it through a DB converter program before.

So i figured out the DB converter (to DBC) is bugged. So i tried doing it manually. I am still experiencing the same problem.

The question is why would these Custom items affect somewhat around 30,000 creature_equip_template rows? and how is it possible? I just don’t understand it.

Any other ideas?

Kind Regards,


It seems that this is a common issue suddenly. Every month people post that they have issues regarding the NPC equipment. (not necessarily on these forums…)

The issue is often that people seem to convert the item_template to item.dbc. Item_template does not contain all item entries that item.dbc contains.
For this reason, replacing the original item.dbc with a generated one will usually lose data which leads to problems.

Not all items in the game are accessible to players. This is why not all items have data in item_template. The items that are not available to players may not have damage or other such stats (or we cannot read that data).
These items are cosmetic and used by NPCs. Let's say for example that there is some special item like a lantern that guards use. For convenience, the NPC equipment system uses item entries from item.dbc. This lantern may not be available for players since we don't want them to use lanterns, but the displayid and such data must be associated with the entry through item.dbc.

What  you can do is to add only your edits to the item.dbc or you can extract the data you are missing from item.dbc to DB so that the converter has all the needed information.
I think the easiest solution would be to try convert the item.dbc into an SQL which uses INSERT INGORE. That way you can make a copy of your item_template, run the item.dbc sql to it and then generate the dbc file and then delete the DB table that contains the dbc info for extraction purposes.