3.3.5a Auction House Bot


I feel like a noob asking this question. I have a lot of knowledge on how to run and setup a Trinity core the past few years and I love the 3.3.5a. I’m not sure what I’m doing wrong with the auction house bot because last time I used it a few years ago it worked fine. I just can’t figure out why it’s not adding items to the auction house. I did notice there were items in the auction house with no seller name on them. I’m guessing it might have started to add items as account 0? Which is by default in the worldserver config.

So I created an account and made a character then added that account ID as 2 which is the account I want for the auction house bot. I then deleted everything in the table auctionhouse to make everything new. Because I wanted to try to change some prices etc. I’m not sure if those items were there already in the .sql or not. I don’t think they would be as a fresh install but I didn’t look either. I did try to add AuctionHouseBot.GUID after checking the wiki. Still didn’t work.


I seem to remember that you need to log in to the game with the AHbot account. Not sure if that’s still required.

Does the worldserver.log give any clue?

Only thing world log says is:

Initialize AuctionHouseBot…
AuctionHouseBot seller not have items, disabled.

I never had to login the account for it to work but I tried that anyway and it didn’t work.

It seems that the AHBOT is broken in 3.3.5.

Roundabout 90% of the auctions on my server from AHBOT have lower “buy now”- then “bid”-prices. This results in not buy-able or bid-able items. I’ve already cleaned the auctions and restartet server/ahbot, but with the same result, all the new items from ahbot are not buy-able in 90%.

Trinitycore compiled version from 01.01.2019

Can someone confirm?

I just compiled mine very recently. TrinityCore-TDB335.64 about 2 days ago or 3.

Sucks it’s broken right now. It use to work. I did add items on a legit character to the auction house and the buyer bot works fine.

you don’t need account for ahbot anymore.

cannot confirm with 17000 items on ah.

Hm…but why is it happening on my system? A config-problem? I guest it’s not possible to create such a behaviour on purpose (creating items in AH with lower buy-prices than bid-prices, because this would not make any sense…)

Could it be some DB-Issues? Some missed DB-Updates? (Autoupdates are activated in Trinitycore)

Edit: OK, I take it all back! I had a typo in my config:

“AuctionHouseBot.BidPrice.Max = 0.9” was “02.9”

I’ve corrected it and now the AHbot is working like it should :slight_smile:

G’day i only just started a fresh install of TrinityCore rev. 2cea7d000c22 2021-04-05 19:44:54 +0200 (3.3.5 branch) (Win64, Release, Static) and i just went to the AH to add auctions and i have auctions already there pic provided is this normal?

even under the database it says i’m the owner of the items, there itemowner 0 there but a list for owner 1 after i removed them all from DB i just added them all under owner 1 myself so i made an other acount called ahbot and character ahbot and now it is adding item under that account