7.2.0 Client 101

When I load the server up I join okay at times but the problem is when I use another computer to join the master branch I get this problem anyone else get this problem. I have no problem with the computer that the server is on but the other computer gets this


This is a auth issue that has been going on that allows for other computers to connect with the server if you look at the other branches like 3.3.5 or even 4.3.4 you will see it is stronger socket when it listens for the connection then it is for 7.2.0

I only get this with master branch, the others work fine.

I sent you a patch file for the connection it is fixed with the changes the socket now listens better, just use git apply thefile.patch

It works much better now I can connect without any problems thanks.

I have another update coming soon

Anyone else that uses 7.2.0 getting this disconnect issue

I’m having the same issue.

Thank god I am not the only one getting this problem, I’m sure there have to be more they just aren’t saying anything. I noticed a server out there running 7.2.0 is working fine so not sure how they got there’s working but I noticed there using :2119 port number after the IP address. I see the port number for auth has changed for 7.2.0 to 1119 from 3724. There has to be something simple to fix this but who knows

Wouldn’t it be wiser to create a pull request with that?

Yeah it would be but I am not done with the patch yet.

Not sure where to put this and sorry ahead of time if its in the wrong place. everything complied without a problem vmaps etc went without a problem

but patching did not seem to work and it probably is something im doing.

directory what i typed and result.

BlizzardError.exe connection_patcher Documentation Interface mmaps WDB WTF
Buildings Data Errors Launcher.db Screenshots World of Warcraft Launcher.exe
Cache dbc Errors.old Logs Utils Wow-64.exe
cameras dbghelp.dll gt maps vmaps Wow.exe
trinity@trinity ~/WOD $ ./connection_patcher wow-64.exe
TrinityCore rev. ed986a416a43 2017-05-10 17:27:59 +0200 (master branch) (Unix, Release, Static) (connection_patcher)
to stop.

/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/

http://TrinityCore.org /__/

Creating patched binary…
EX: could not open wow-64.exe
An error occurred. Press ENTER to continue…

Are you dragging the client on the connection patcher because you cannot run connection patcher by it self and patch the client.

[COLOR=rgb(39,42,52)]wow-64.exe != [COLOR=rgb(39,42,52)]Wow-64.exe

Also, i am not sure you can patch windows binary on windows.

Nemo does not do anything when i drag and drop so i ran it on the command line and tried both wow.exe and wow-64.exe. The operating system is linux mint. Just trying to set up a linux server for wow

./connection_patcher wow-64.exe

Thank you it was the cap w that got me sorry for the waste of your time.

BTW once its patched. (server has a static ip of and coded into the 2 config files can i copy the wow directory back to a windows machine and have it run?

Have compiled 7.2 and i can connect from other pc’s in my local net but none of the chrs can purchase anything from the vendors. The items show up but i can not purchase anything. I can sell junk to them tho. Is this a setting issue someplace or a bad make issue? game does not crash or DC. Not sure where to look.