My ( trivia ) question is simple: isn’t more proper calling trinitycore scripts → trinitycore plugins instead?
I’m from old-school w0w emulation and i’ve followed this kind of “scripts evolution”:
[ wad emu ] TCL interpreted creatures scripts → [ mangos ] c++ compiled external dynamic library creature scripts → [trinitycore ] c++ compiled classes/listeners that act using observer pattern allowing you to change the behaviour / flow of the overall system .
Now, Maybe someone can agree with me that they shouldn’t be called simply scripts anymore , but something such as plugins / modules would be more accurate. i know the naming is not the most important part of developing. But sometime it can be a good way to understand the system architecture and how to add functionalities.
Could you explain me better if is there a specific reason to continue calling them scripts.