Follow Tutorial => missing table


I have some problems with database 3.3.5.

What i did :

create_mysql / auth_database / characters_database

Now i DL : [COLOR=rgb(0,0,205)]TDB_full_world_335.60_2015_11_07.sql

and i start :

world_2015_07_14_2015_11_07 => error

characters_2015_08_26_2015_11_03 => error

auth_2015_08_21 => error

all for missing table …

However, i follow 2 tutorials … and i can’t follow it :

Because :

Someone can help me to explain what i forgot. Thx

Sorry for my bad english

ps : I search and any time “apply update” That not work

The wiki is fucked atm heavily.

But you have to explain more in detail what you have done and what kind of error you got.

I have just problem with .sql

so like i said, i created DB with [COLOR=rgb(39,42,52)]create_mysql + auth_database + characters_databaselike all tutorial said.

[COLOR=rgb(39,42,52)]After that, all tutorial says : Apply TDB full 335, so i dowloaded last relaese : see in first topic.

[COLOR=rgb(39,42,52)]And when i applyed that :

world_2015_07_14_2015_11_07 => Erreur SQL (1146) : Table ‘world.version’ doesn’t exist

characters_2015_08_26_2015_11_03 => Erreur SQL (1054) : Unknown column ‘corpseGuid’ in ‘field list’

You are not supposed to run the update files from the TDB download if you are creating a new DB.

Instead you only run the TDB full sql file to world database and then you run the updates from sql/updates/world which is located in the source you downloaded:

Far easier way of setting up the database is by using the new system that creates it for you.

[ol][li]Delete existing databases[/li]
[li]make sure the database creation system is enabled (under UPDATE SETTINGS) and database settings are correct (under CONNECTIONS AND DIRECTORIES) in worldserver.conf[/li]
[li]Download TDB full and place the files to server folder (so the TDB full is next to the worldserver.exe)[/li]
[li]start worldserver.exe and press enter when it asks if you want to create databases[/li] [ul]
Note that if you get errors you may have deleted or moved the source folder that was used to compile the server.
In that case you should download the source and set SourceDirectory to the source path under CONNECTIONS AND DIRECTORIES in worldserver.conf.

		[li]Otherwise check your mysql login credentials and read the error message as it may tell you what to do.[/li]			

[li]once server is up you can start using it normally[/li]	


What you have imported are only update files. You don’t need them.

Just import only the TDB_full_world_335.60_2015_11_07.sql

It creates a new full world DB.

To create the table structures of auth and character DB use the auth_database.sql and characters_database.sql in your sql/base/ folder of TC source code.

Use the autoupdate feature to update your DB.

Unfortunately I have to say with a defective wiki it’s a hard job for a newbie to setup all the necessary stuff.

That’s cool. Didn’t know that :slight_smile:

Ok, so, i deleted all.

[COLOR=rgb(39,42,52)]Updates.AutoSetup = 1

[COLOR=rgb(39,42,52)]Updates.EnableDatabases = 7 (<=> ALL)

LoginDatabaseInfo = “;3306;trinity;trinity;auth”
WorldDatabaseInfo = “;3306;trinity;trinity;world”
CharacterDatabaseInfo = “;3306;trinity;trinity;characters”

In HeidiSQL, i created a new user :

user name : trinity

user password : trinity

Privileges : ALL

Now, when i started worldserver :

Applying of file ‘create_table.sql’ to database ‘auth’ failed! If you are an user pull the latest revision from the repository. If you are a developer fix your sql query.
Failed to create database auth! Has the user CREATE priviliges?

DatabasePool Login NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors. Read wiki at

However user exist and privileges too …

ps : In past, with wamp it was really simple … now not really

And when i apply create_mysql and auth_database + characters_database

Worldserver : >> File “TDB_full_world_335.60_2015_11_07.sql” is missing, download it from “” and place it in your server directory.
Could not populate the World database, see log for details.

but in :

I have no file named : TDB_full_world_335.60_2015_11_07.sql …

And in :

There are no files …

Here I found a download link:

There is a zip file with TDB_full_world_335.60_2015_11_07.sql

But I like Rochets post of creating db’s very much if is working :wink: Never tried.

Edit: ok, after you edit your post it seems you found it already ^^

I try again but i download (.7z) it before, it contains : updates_tdb_33559_to_33560_only (folder) which contains :




not [COLOR=rgb(39,42,52)]TDB_full_world_335.60_2015_11_07.sql

[COLOR=rgb(39,42,52)]And Source code zip = my source folder

[COLOR=rgb(39,42,52)]I really don’t understand …

[COLOR=rgb(39,42,52)]I have NO file named [COLOR=rgb(39,42,52)]TDB_full_world_335.60_2015_11_07.sql

Must i rename “world_2015_07_14_2015_11_07” in "[COLOR=rgb(39,42,52)]TDB_full_world_335.60_2015_11_07.sql " ???

Corrected the steps a bit above.

The sql should be right next to the folder.

Oh, i’m so sorry, i didn’t see … -.-

But now : worldserver :

Database World is empty, auto populating it…
>> Applying ‘TDB_full_world_335.60_2015_11_07.sql’…
Applying of file ‘TDB_full_world_335.60_2015_11_07.sql’ to database ‘world’ failed! If you are an user pull the latest revision from the repository. If you are a developer fix your sql query.
Could not populate the World database

Maybe one day that will work ><

no problem, had the same problem 2 weeks ago when I tried to install WOD :slight_smile:

Are you sure you have correct SQL rights ? May try to add ANY new test database and a table manually with your sql client and your trinity user to check.

That’s ok !!!

So :

I applied TDB … sql with HeidiSQL … because with worldserver that didn’t work.

AND ! after new error i renamed :




to :




And serv is up !!!

Thx Magnuss and Rochet2 ! ^^

hmmm, any idea why you need the underscore ?

May this will occurs problems when you are pulling new updates from the repository.

In fact, in try to upload all time … so i changed name of folder and worldserver can’t found update and so, it doesn’t crash.

I don’t know why it doesn’t like it x)