How to make gameobjects work

Hi there,

I’m just playing around doing some quests and was wondering which steps I basically need to take to get gameobjects to work when doing a quest.

I.e. I’ve done the quest An Old Gift, where I need to click on a book which lies in a doorstep. This book is present in the world, however I can’t click on it. Also it’s not sparkling like ‘click on me’ :).

What I don’t know is what steps need to be taken to make this work. Who can tell me what needs to be done?

Is it the right gameobject?
Are the flags correct on the gameobject?

Are you working on 3.3.5a or 7.x?

Hi CDawg,

I’m working on 7.x and was trying to get a grip on where to look and what to edit. I’ll check the flags first and post what I find. Do I need to edit WDB files as well or should that never be the place to look for?

For 7.x, I dont believe editing anything for the local client to get results to the server in the wdb. However, maybe someone can assist answer that once you modify the gameobject on the server db, that you may want to clear cache to until you get the results you desire.

Even for 3.x I occasionally have to delete cache dir for certain server changes… I know 7.x is pretty heavy on client storing now.

Thanks! I’ll try clearing the cache as well. I added an entry in the gameobject_loot_template table. There the ‘loot’ gameobject wasn’t registered to drop the book. The cache needs to be deleted from the Wow client, right?

I would only clear the cache from client if you don’t see the changes in world once you made them on the server.

Well I’ve tried a lot but no success yet.

I’ve compared the Olemba Cone gameobject 182541 to Glowcap gameobject 182053. The Glowcap gameobject works when clicking on it in Zangarmarsh. Compared it with gameobject, gameobject_template and gameobject_template_addon.

Almost everything is the same with exception to the gameobject id’s/entries in the tables. Flags are the same. What I don’t get is why I can click on the gameobject Glowcap (shows tooltip display and cogwheel when hovering over it) but the Olemba Cone (containing the seeds) does not. Both gameobjects are of type chests (type 3) and are in fact containers for items.

Has anyone stumbled across the same problem?

After applying database changes and restarting the worldserver I also clear the cache clientside. This however doesn’t change a thing unfortunately the Olemba Cone is still not clickable.

I went over everything you just said and even did the same steps as you did and I am able to click them just fine even the quest in Stormwind when you have to collect the apples around Stormwind work for me I am able to click on them as well.

Maybe I am missing something you said, but I even tried adding my own quest with a custom item and I am able to collect the tablets as well for my quest. I did this after the one item you said wasn’t working just to make sure I was able to enable the clickable item.

I also make the quest with a script too so I could make it clickable only during a quest and no other time. I will go over it again so I can try to hopefully get the same issue you are seeing so I can try to figure out what is locking you up and to see if I can get the item not to work for me so far no luck.

Hi codeman!

Thanks for trying, I’m puzzled why mine doesn’t work and yours does. If I would add screenshots of the database entries that might help?

Do you use other tools to add things to the database? I mean I look things up with SQL statements (and change things on the database) using NaviCat.

I’ve corrected for other things the gameobject loot for silver vein and small thorium veins in the gameobject_loot_template and that did work. So I can say that some changes work after restarting, which leads me to believe that I’m doing something wrong for the Olemba Cones.

Can we do a comparison of the gameobject, gameobject_template and gameobject_template_addon database entries? Yours versus mine?

What I do notice is that when there are gameobjects involved in quests these almost always are broken (present in the world, but not clickable)

i notized that gameobjects type 3 = chest has data 0-32 in client 7.xx

in description are both data1 and data30 involved in loot.

from wpp the needed quest_loot is stored to data30

but our core need quest_loot in Data1…

so the gameobject is not “glitter” and is not “clickable” : quest can’t be done…

is this a failure from wpp or a failure from core???


The Data1 field should contain the “Entry” value in the table gameobject_loot_template

I do not see you mention this table, it needs to have a valid entry.



@AussieGuy if you look at trinity wiki… yes you have correct…

but as demo: look at gameobject 32 : server linkin is

you see: loot should be Oslow’s Toolbox = item 1309

in T725_world.gameobject_template you find in data1 an value of 1683

in T725_world.gameobject_loot_template for entry 1683 you find loot 1309…

so wiki description and content of the table are not valid…

(and if you search more… if wpp fill data to data30 and data1 is then set to 0… all this quest are broken… )


It seems to work fine for my custom quests.

Without all relevant tables including quest_* then I cannot see a way to help you further.



Hi AussieGuy and gpn39f,

Thanks for your replies, what would you advise me to do further? Check the gameobject_loot_template for entries for in my case the Olemba Cones? Olemba cones are quest related objects.

The application I use is custom made I make all my applications either using Xojo or Livecode depending on the project but most database or MySQL programs I make using Livecode because it supports MySQL and most databases really well.

I am also working on a new application that controls all the database tables and allows you to add data to the database a lot easier like game objects, loot, quest, npcs, commands and so on. It is going to allow for easy editing of the database and allow for error proof to the most of its ability.

I am also wanting to do something new with the search abilities to allow for copying other items so you can search for one field and use it as a template so you can create the next item, npc, command or so on.

For reading books in gameobject_template:

  • that gameobjects are type=10

  • for showing the tooltip iconname=‘inspect’

-for showing the text data19=1

For gameobjects type 3 giving quest loot:

  • in gameobject_template, data1=lootid (if its 0 you can use the gameobjectid)

-in gameobject_loot_template, entry=data1

  • in gameobject_loot_template for items objectives of a quest, QuestRequired=1

And the gameobject should to give the quest item.

The issue that you mentioned maybe happens because one of the chest drops normal items and quest items and the other one only drops quest items. So the chest which drops only quest items doesnt show the loot tooltip if you havent taken the quest. If this isnt the case so surely its because trinity has changed the way to add quest items in database and the most of them are broken.

Before quest items in loot were added in db writting negative chance in the loot_template table. You have to use the new field named questrequired in loot_template table now for adding the quest items in loot.

Hi Daniel,

Thanks for your reply. I’ve also checked these entries you describe when gameobject is type = 3 (Chest). This is the case for Olemba Cone gameobject. The only way I got this working was to change questrequired = 1 to questrequired = 0. But… that would mean it would be clickable at all time regardless if there was a quest.

Anyone got an idea to get it working with a quest? My question is still what might be out of place here?

If it didnt work the way that i told you, so surely the questid in that gameobject is wrong in gameobject_template. You should to check that. Everything works good for me.

Data8 column in gameobject_template (which points to completed questid) has value 0. Do you suggest to populate that with the questid?

Have you tried switching the data over to that field because I think I might know why it is not working for you could you take screen shots and send them to me because I would really like to figure out why this is not working for you.

Be careful using navicat because it is not something trinitycore wants users using when it comes to statements and running queries because the way it handles that data sometimes and formats.