Looking for Clean/Fresh TC 3.3.5a Linux files

Dear TC Users!

Heres a little briefing about my issue:
- I tried to compile the TC 3.3.5a emu at my linux server (debian 8 and ubuntu 16 - newer versions are not allowed on the server - hoster provides). I tried everything from the tc wiki, but sadly without any success.
PS: I have the Windows version, its working perfectly at localhost.

Is there any ways, to someone give me a link where I can download the fresh and clean TC 3.3.5a (https://github.com/TrinityCore/TrinityCore/tree/3.3.5 this one) files (base files + extractors, BUT without vmap, mmaps, dbc) which already maked for Linux?

Sadly I don’t know anything about the VM and the Cygwin programs only heared about them, but never used.

I hope someone can help me with the Linux core files :confused:

use debian 8 with clang, if you need newer clang use clang repo to get clang 5 or newer, you may need to compile boost yourself.

Finally I get to worked on Ubuntu 16.x, but the following errors appears now:




Additional error:


Followed guides:


OS: Linux Ubuntu 16.x
Ram: 32 GB
Cpu: 8 core

Used commands:

apt-get install git clang cmake make gcc g++ libmysqlclient-dev libssl-dev libbz2-dev libreadline-dev libncurses-dev libboost-all-dev mysql-server p7zip
update-alternatives --install /usr/bin/cc cc /usr/bin/clang 100
update-alternatives --install /usr/bin/c++ c++ /usr/bin/clang 100

Any ideas how can I fix it, or anyone met with this issues?

on ubuntu you must compile boost yourself, uninstall systemwide boost.

Thank you, I try it :slight_smile:

I hope it will work  :) 
  1. downloaded from here: https://sourceforge.net/projects/boost/files/boost/1.62.0/ and extract with tar -xf boost_1_62_0.tar.gz
  2. cd boost_1_62_0
  3. get required libraries:
    sudo apt-get update && sudo apt-get install build-essential g++ python-dev autotools-dev libicu-dev build-essential libbz2-dev libboost-all-dev

    build with ./bootstrap.sh --prefix=/usr/local
  4. install with sudo ./b2 install


Thats normally, the GCC 6.3.0 takes ages to MAKE without install?

Followed this guide:

  1. [li]wget https://ftp.gnu.org/gnu/gcc/gcc-6.3.0/gcc-6.3.0.tar.bz2[/li]tar jxvf gcc-6.3.0.tar.bz2
    cd gcc-6.3.0

    Compile the sources (note: this command will differ depending on where you initially saved the .bz2 archive), you can also modify option for build command. In this case we’ll use very basic option:

    cd ~
    mkdir gcc-build && cd gcc-build
    …/gcc-6.3.0/configure -v --prefix=$HOME/gcc-6.3.0

    NOTE: Make sure you have read the docs to view available option.
  2. Now we are ready to build gcc

    Run make command to build gcc, this steps will take a long time to complete.


    Once the above phase is finished, you can install built gcc with:

    sudo make install