Mangosbot/Playerbot compile errors - Debian 8.5

Hello -

Does anyone mess with this particular flavor? I installed a new Debian 8.5 server, nothing but the basics. I installed the needed packages, setup a git clone for brand trinity-wotlk-ai (3.3.5), and tried to compile. I can compile this on Windows, but not linux. I can, though, compile the normal trinity build. I tried this a few days ago but not sure which commit/build as I deleted it once I knew I could at least compile it. (sorry!)

I didn’t really look through the build logs on Windows since it compiled fine, but I assume the issues below are existent there as well, but just don’t stop it from finishing. In linux, I’ll see warnings from compiling some of it, but then it gets all the way to 100% progress then dumps the whole thing.

Here’s the output of cmake -

Here’s the output of make (errors/warnings only) -

This server is a virtual machine, 22 cores and 32GB memory. The commit I’m grabbing for mangosbot is 9fefd30dabd9d5e8be82651e288feeb9b5025c22 and I also tried the previous, which is 55b583d1726fe70d55c4b9efab476d3fa0710ae4 and got the same errors.

The directions for mangosbot were to clone whatever branch you want for it, then follow the same directions for compiling/installing TrinityCore. I went through these step-by-step and cannot find anything else I could do. Anyone have any ideas? I’m with limited coding knowledge.

Note - I also tried Ubuntu 16.04, as well as Fedora (23 I think? whatever is the latest at this point) and got the same compile errors on those as well.


Issue was resolved, see above if you use mangosbot / playerbot and have run into this